kicker 750.1 Green light no sound

Status
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.
This is from a previous post:


Can anyone help me try to figure out why I have no sound from my kicker amp even though the green light is solid. I have called kicker and they no longer provide schematics and I don't really know what to test. I have eliminated the board that contains the gain and all that by taking it out of a good 750.1 I also know it's not anything related to the wiring in the car as I hooked a different amp up in the same spot and it works. I know it's somewhere on the board but no tell tell burnt components.

I checked all those before with good results I checked the preamp board with a 12v result it appears that the signal dies in a component under the preamp board but I am unsure of what to look for in that region.


I tested the LM361N chip today here are the results:
12.1 volts dc in
pin
1 12.06 V
2 0
3 -4.016 V
4 0
5 0
6 -12.01
7 0
8 3.289
9 3.019
10 -2.182
11 3.268
12 0
13 3.288
14 3.288

can anyone verify these as correct or is this the chip i need to replace?
 
If the other Kicker 750 you have is known good, same rev level & works clear space on your bench, open it up and hook it up side by side with the defective one. Make sure all the switches and controls are set the same on both amps.

Hook up a common ground between the two for your meter & O'scope. Why guess if a voltage or waveform is right when you can know for sure. When taking measurements you can then focus your efforts on finding out why a waveform or voltage is wrong instead of wondering if it is right.
 
Last edited:
I will have to measure them tomorrow and let you know as the power supply i use is at work. are the output transistors on the left or right hand side also I have a large yellow cap that is loose. What I mean by loose is it's the only one you are able to shake back and forth do you think that may have anything to do with it?
 
Status
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.