• WARNING: Tube/Valve amplifiers use potentially LETHAL HIGH VOLTAGES.
    Building, troubleshooting and testing of these amplifiers should only be
    performed by someone who is thoroughly familiar with
    the safety precautions around high voltages.

feedback problems

I finally renovated an EL80 amp but I am having problems with the feedback circuit. Without feedback the amp sounds really tinny but with feedback on the 16r opt secondary I get a low level sine wave sweep. Seems like the feedback is positive. I've enclosed the schematic and I need about 18dB feedback. Any other ideas how I could implement this?

I tried connecting the feedback to both the phase splitter as well as the driver cathode with the same sweeping problems.

The EL84's are cathode biased push pull in pentode mode with 60mA current per tube. Anode voltage is 280V for driver, splitter and power tubes.
 

Attachments

  • pp_sv83.gif
    pp_sv83.gif
    11.3 KB · Views: 199

tubewade

Member
2007-06-03 8:54 pm
I would administer the feedback at the input valve cathode. The sine tone you are experiencing indeed sounds like positive feedback. Did you ever have the anode leads of the output transformer disconnected from the valve sockets? Perhaps they did inadvertently get switched?

Was the high-Z input wiring kept well away from the output wiring and feedback wire so as not to introduce some positive feedback by capacitive coupling?
 
Hey tubewade, thanks for the reply. Yes, the input wiring is well away from the output wiring. I don't quite understand what you mean by the opt leads bing switched. Shouldn't it not matter which leads from the opt are connected to which EL84 plate?

Tomorrow I will try switching the leads on the EL84 plates and see if the positive feedback persists. Should I switch the leads on both the channels?
 

chrish

Member
2003-10-20 2:43 pm
Sydney
It very much matters which way they are wired, as you have found out!

The feedback will be positive if the plates are wired one way (what you appear to have), negative (what you want) if they are wired the other way.

You can either swap the wires from each of the EL84 plates (pin 7) to the output transformer, OR you can swap the ground and feedback wires from the secondary of the output transformer. Each channel must be wired the same way.

Sod's Law states that given a 50/50 chance of wiring it up backwards, you will get it wrong 90% of the time ;)

Good luck, hope this solves your problem!

Chris
 
audio_moksha said:
I finally renovated an EL80 amp but I am having problems with the feedback circuit. Without feedback the amp sounds really tinny but with feedback on the 16r opt secondary I get a low level sine wave sweep.

What do you mean by "low level"? What's the frequency of the spur? Every time I've had the phasing of the gNFB wrong, I basically turned the whole amp into a high powered Royer oscillator, with the output being ~25Hz square waves at full power output levels that could easily burn up a test load resistor, as well as poofing the finals, if not disconnected real quick. There was nothing "low level" or "sine wave" about it.

Seems like the feedback is positive. I've enclosed the schematic and I need about 18dB feedback.

More gNFB than I like, but c'est le vie!

I tried connecting the feedback to both the phase splitter as well as the driver cathode with the same sweeping problems.

Don't do that. Connect to the cathode of the input stage only. Are you actually using the 16 Ohm secondary? If not, then take the gNFB off the secondary you are actually using. By connecting to an otherwise open tap, you could be getting some spurious positive feedback caused by a resonance in the secondary windings. It could also be nothing more than RFI that you're seeing. Using an open tap can cause that too since the impedance there is extremely high.
 
The opt leads going to the EL84's were switched. Now that I have them the correct way the feedback works fine and the amp sounds much better! Thanks for the input gentlemen.

Hey Miles, when I said that the sweep was low level I meant that it was loud enough to be heard at 1m from the drivers. Sometimes it swept from about 250Hz up and sometimes it went from 10kHz down. But anyway now thats all gone. You're right; the 18dB nfb sounds too much I will try using lesser feedback.

Also what are the differences between current and voltage feedback?
 
audio_moksha said:
The opt leads going to the EL84's were switched. Now that I have them the correct way the feedback works fine and the amp sounds much better! Thanks for the input gentlemen.

Good that's fixed. :)

Also what are the differences between current and voltage feedback?

Current NFB reduces Zi and voltage NFB increases Zi. If positive, it does the opposite.

You're right; the 18dB nfb sounds too much I will try using lesser feedback.

What I'm doing now is amking the gNFB adjustable. For the latest project, I find that ~13db(v) of gNFB definitely makes some material sound "subdued" and tending to a "solid statey, Big Box" sound.
 
Hey Miles, I felt the same way with about 18dB nfb; it almost sounded like a solid state amp; a lot less distortion but a lot less warmth as well. I also found that by using the 16r tap i got clicks and pops that I suspect is due to the infinite impedance. I'm going to use the 8R taps today and reduce the feedback to about 6dB to 10dB.