• These commercial threads are for private transactions. diyAudio.com provides these forums for the convenience of our members, but makes no warranty nor assumes any responsibility. We do not vet any members, use of this facility is at your own risk. Customers can post any issues in those threads as long as it is done in a civil manner. All diyAudio rules about conduct apply and will be enforced.

dScope Q&A thread

Hello folks,

I've read some discussions on this forum about our family of dScope audio analyzers so I thought I'd join the discussion to answer any questions that you may have regarding our dScope Series III and our new affordable M1 range. Please post you questions, comments or suggestions in this thread and I'll come here to answer them. I hope to be of some value to the diyAudio community :).

For formal enquiries we can be reached through support@spectralmeasurement.com

Best regards,
Ismo Aikomus
Applications Engineer
Spectral Measurement (formerly Prism Sound Test & Measurement)
Hi Ismo
Nice to know ! I have a dScope III and love it it really make my service job easier, but now I ran into a problem .
I was setup mulitone that sudden the software froze and now I can not get in contact with the dScope it say at boot : "Visual C++ runtime error"
and halt

I can run the program without hardware , can you help me there ?
Thanks for reaching out,

I'm glad to hear that you're loving your dScope!

Off the top of my head I don't recognize this behaviour. Could you send me some more details? If you email us at support@spectralmeasurement.com, I can send you the details to enable software logging to get more information.

-Does the message pop up during the splash screen or when the whole GUI has loaded?
-Do you have any startup scripts / configurations set in the software settings?
-Which Windows and dScope software versions are you running? You can check the dScope sw version in Help -> "About dScope"

Best regards,
I was doing some multitone measure and the software hang and crash. I try running it again and it gave me the fault. "Runtime Error" , attach a picture.
No startup scripts. - I did change the Default Path for ver. setup files to my home dir. Because dScope complained about not being able to write to default dirs.
Win10pro - 19044-2006 64bit - dScope : 1.45h 64bit

I also send you an email to you.


  • prism.png
    6.4 KB · Views: 25
Thank you for the details,

I'll check this with my colleagues and will get back to you via email.

The newer Windows versions do complain about the writing access to the default dScope directories. The new version (1.50 onwards) of the software has the default directories under My Documents to avoid this. The 1.50 can be used by both dScope M1 and Series III models and can run in parallel with the previous versions. If you want to upgrade the software, you may need to update some of your test configurations and scripts as well but it is recommended to ensure future support. You can download the software on this page: https://www.spectralmeasurement.com/pages/m1/

This sounds very odd. I assume you've booted both the PC and the dScope already?

I haven't seen your email come through yet. In case there is a problem with the email, could you try sending us a message through the chat-widget on the bottom right corner of our website: https://www.spectralmeasurement.com/contact-us/

Once I have your email, I can send you the details for enabling the software logging.
The luck smiled at me from the ElecTron goddess, I flip the lite of the dScope, with deattach wires, and pike around evertyhing looked ok, press a couple of chip/socket. And power on the dScope again with ver. 1.50 and it BOOTED !!!! Gone was the "Runtime Error" and everything seems to work again !?
So I guess we will not solve that problem before next time :-] .
I will use it intense the coming week and we will see.
Thank you for your support
p.s. Should I clean the sockets on the add on board !?!?
As Ismo is no longer with the company I thought it worth picking this thread up.

In case you are still wondering, thumb, you could clean the edge connectors if they look dull, but it should not be necessary to do it routinely. Removing and re-inserting a couple of times might help secure a good mating connection.

If anyone has any questions about audio measurement in general or our dScope audio analyzer system please feel free to ask.
Last edited:
As for now it works once sometimes I can get it to hang in the software where I loose touch with Dscope and have to shut down the box and software to get it to run again. And it is random I try to see if it is the problem but it is not. But it is a very fine device you have made here and it fit my needs in the service/production shop I am in. So keep up the good work!!
p.s. I also enjoy your video lessons to brush up and extend the school days ;-)