Can't play flash movies

when I go to

this game page

at work it's all good. At home, I can't get it to do anything but show a black box where the game should be. I have problems playing flash movies apparently...

I went to macromedia and downloaded the latest version, saw the little movie play on their site, still with the black box!

:confused: :dead: :att'n: :bawling:

edit: wondows media won't work either... just tried to watch the karate master at compfused.com and it downloaded all those megabytes with the controls greyed out, and kicked me backwards on page!
:whazzat:
 
? It's a '97-vintage ATI All-In-Wonder Pro... Before I upgraded from 233 to 1.8G Hz processor with new mobo a while back, I guess I never tried to download stuff at home to watch (dialup). The thing is, since I can watch movies if they are saved files at the house, it's never been a problem to grab them from the cache or the website directly, but this (very fun) game is nested in a way that I don't know how to dig out; part of a page that I don't have permissions for. It also occurs to me that this is the first flash that didn't work for me at home, but I have always had problems with .wmv's