Audiopipe APCL-1800.1d power supply scheme

Status
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.
Does anyone know which transistors go where for this amplifier. I can't seem to get the power supply working. Alot of transistors were burnt up. So I'm need to know what goes in
Q28
Q38
 

Attachments

  • 15833767681794266817183059654924.jpg
    15833767681794266817183059654924.jpg
    1,003.2 KB · Views: 87
Got power supply up and running. All the outputs test good.
However, when I placed the rectifiers into curcuit the amplifier will not start just draw strange current and flash protection very fast. I believe the last Amp. Like this I worked on the cause was one of the 78M05 on the board causing it.
Is this the output board?
Should I remove the output transistors for testing?
 
No shorted output when I received it. However, I can see that someone has changed the regulators previously
Well 2 of the three have been changed.
I have 2 extra cards with new ic on them.
Something burnt the power supply up badly?
My power supply just clicks fastly, these amps have done this to me before. Generally beacuse an output is shorted.
A different output card makes no difference.
 

Attachments

  • 1583628943200258708031570312223.jpg
    1583628943200258708031570312223.jpg
    1 MB · Views: 68
  • 15836289678796926475866241204949.jpg
    15836289678796926475866241204949.jpg
    1 MB · Views: 61
Status
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.