Anyone here use this TPA3255?

I started working on this. Ive installed the Board in a Power Amp chassis I bought that was like new. Im using a Meanwell EPP 300 48 power supply with it. Nice and compact specs are 48v at 6.25 amps. I actually have two of them. Is there anyways to use both of these with this board or is it even worth it. Specs on the board state 600 watts which I know is horse shizz. THe power Supply DC ouptuts are V+ and V- and the amp pcb looks for V+ and Grnd. WHats the difference as I have V- fmor PSU to the Grnd input on the AMp PCB and obviously V+ to positive. Any additinoal grounding need to be done? Its mounted on metal standoffs both supply and AMp. Power input (AC) is grounded to Chassis and Pin 1 of PSU also to chassis ground. AM I missing anything?
 

Attachments

  • TPA3255_Dual_Build.jpeg
    TPA3255_Dual_Build.jpeg
    117.8 KB · Views: 108
power Supply DC ouptuts are V+ and V- and the amp pcb looks for V+ and Grnd. WHats the difference as I have V- fmor PSU to the Grnd input on the AMp PCB and obviously V+ to positive.
If you connect (-) from the PSU to the GND of the amplifier and (+) from the PSU to the (+) of the amplifier, you will get double the voltage, which can fry the amplifier.
Does that Mean Well PSU have dual DC outputs +/- and GND or just one pair of outputs?
 
It has a connection for a switch which I believe is also mute as there is no Pop noise etc. I have it wired to on off switch, noi thump etc. Sounds really good. Powerful.
 

Attachments

  • IMG_0971.JPG
    IMG_0971.JPG
    528.3 KB · Views: 61
  • IMG_0970.JPG
    IMG_0970.JPG
    594.4 KB · Views: 61
  • IMG_0969.JPG
    IMG_0969.JPG
    561 KB · Views: 57
  • IMG_0940.JPG
    IMG_0940.JPG
    393.3 KB · Views: 56
  • IMG_0941.JPG
    IMG_0941.JPG
    412.4 KB · Views: 54
  • IMG_0968.JPG
    IMG_0968.JPG
    556.6 KB · Views: 54
  • IMG_0975.JPG
    IMG_0975.JPG
    439.2 KB · Views: 51
  • IMG_0972.JPG
    IMG_0972.JPG
    559.4 KB · Views: 56