Android <-> ADC USB isolation

TNT

Member
Joined 2003
Paid Member
I want my phone that I use for field recording data storage out of the ground equation. Also external power feed for long recording sessions.
  • I have a working recording system using an OTG cable between the ADC and the phone.
  • In order not to drain the phone from power feeding the ADC, I have made an y-split cable to connect a IKEA USB battery bank - it works good.
Now, introducing a USB isolator with possibility for power feeding downlink device.
  • Using an ordinary USB-A to USB-micro (phone), the phone is charging from a battery bank (an other IKEA unit)
  • Using an OTG cable, the phone is not charged.
  • In none of the two cases above with the isolator do I get any signal transferred. The phone app says in both cases: "No USB recording device detected".
Units involved are:

I have tried most variants in which order the different things (units, power units, cables...) are started up and connected to each other.

I have tried the Isolator between an RME Digiface and a Mac Mini - it works and sound OK. (perhaps even an improvement actually..)


Why? Any hints or suggestions or obvious errors made? What could be the problem?

Thanks in advance...

//
 

Attachments

  • no_otg.jpg
    no_otg.jpg
    209.7 KB · Views: 59
  • otg.jpg
    otg.jpg
    162.6 KB · Views: 60
Last edited:
AFAIK Using an OTG cable as you use it in some cases you have to enter the general and/or notifications menu of your mobile and check Power Supply (if any).
Hoping I understood your situation correctly.
However, an Android version update (if feasable) might also help.
 

TNT

Member
Joined 2003
Paid Member
That worked ;-)

Almost - for some reason 16b and 32b recording seems fine but when set to 24b (all for 384ksps), the VU meters go to the roof with some slight movement while red... strange!!

Now how to power feed the Mobile for long recording sessions... an other y-split USB-C_USBmicro cable!?

wo.jpg


//
 
Last edited:
Please note that GTO cable are not the same than USB just because they have an additional pin (a fifth pin connected to the fourth) on the USB-C connector side connected through a resistor to the phone, so the 2 ends are not interchangeable and GTO cables never have 2 identical connectors at their ends.
I think the issue you described could also has to do with grounding (not sure, though), and I believe that if you delve deeper into the topic and/or into some experiments you will come to a solution in that regard.
 
I disconnected the isolator, set it up to 24/384 and it recorded fine. If it relay is 24 bit I'm not sure but I think so - some earlier observation of the data indicates that it is 24 bit indeed.
There is no need to guess, the device itself reports its capabilities. lsusb -v -d VID : PID or /proc/asound/CARD_NAME/stream0 in linux, https://www.uwe-sieber.de/usbtreeview_e.html should do for windows.
 

TNT

Member
Joined 2003
Paid Member
Okey - no such command.

I check with what I have... the native audio setting application Audio/Midi lists 24b as an option.

interface.jpg


and my DAW, Amadeus Pro - both seem to accept that 24b can be negotiated and set. The Amadeus has a Quality pane with a button that says Adjust hw as I understand it .. once pressed it changes form 16b to 24 as requested, took a second but it change to and acknowledged 24b.

amad adj.jpg


Amadeus Source setting panel:

amad1.jpg


Checking the device in under System Info gave.... but no bit info...

usb.jpg


To me it seems like the ADC offer 24b - I will try to enter that command to see what it gives...

//
 
It may seem but we have no idea what goes between the device and these screens. The ultimate information is the actual USB configuration. Either directly, as e.g. listed by lsusb -v in linux (using the userspace libusb library), or reported by linux usb-audio driver in the stream0 file (e.g. https://alsa-devel.alsa-project.narkive.com/OJHvIzOP/correction-audiophile-usb-stream0-output )

There are more libusb-based USB viewers, maybe even for mac. You can try some.
 
  • Like
Reactions: 1 user