Amp Camp Amp help v1.8

So I'm pretty new to this, obviously why I'm here, also my first time posting on any forum. I'll try to make this short. Just bought two ACA v1.8 amps to run XLR balanced bridged with switch for all options like default for 18w I think it was for each of my bookshelves. My bookshelves are 8ohms. I have multiple years of soldering experience in FPV drone building. So one amp came out perfect. The other not so well. I looked at other posts here and check that most of my connections if not all are fine. My joints look fine imo. They looked better before I had problems and tried to reflow my solder with more flux. So very strange I accidentally mounted the RCA input connections in the wrong order so I had them grounded at first. Fixed that then boom check biased ran them switch position up bridged for a few hours(realized switch up is not balanced I believe). The third time turning them on low volume all of a sudden I notice one isn't working. This is when I tried reflowing and measuring ohms and voltage as per picture in step 56 in ACA amp build guide 1.6. to see what happened. I understand the very basics of electronics but is quite confusing for me to try to understand the PCB schematic hand in hand to figure out where my problem is. I am thinking maybe someone with more knowledge and experience can come in and save me some headache and time. Here are my measurings:
Bad side(Input A)
Q1: S 0ohms D:3.5k G:6k
R10:2.9k
R9: .5k
Q4 D: .5k
R15(a): 3.6k
R15(b): 3.9k
R5: 4.3k
Q2: S: 3.5k D: .5k G: 4.4k

Voltage:
Q1: S: 0v D: 0v G: 20.2v
R10: 21v
R9: 21v
Q4 D: 24v
R15(a): 0v
R15(b): .6v
R5: 1.7v
Q2: S: 0v D: 24v G: 1.7v


I just measured the other side that plays music and its measurements are right on the money it looks like.

I did other reheating and triple-checking wires and triple checking measuring even though the numbers were out of whack due to what I believe was a really old battery in my multimeter BEFORE they worked. I got the bias close and ran them. I'm thinking it's irrelevant because clearly I have something wrong now seeing that it doesn't work anymore and I have 20+ voltage in places I shouldn't. I will attach photos of the bad channel PCB and any help/tips/corrections/theories/predictions/suggestions would be very much appreciated.

Sorry for the not-so-perfect photos and messy job. I was really hoping I would breeze through both amps with cleanliness but now I just want to figure out what's wrong and have this over with. I'm pretty sure I'm missing a few things I wanted to mention. I also just noticed I posted this in a different category from exploring. whoops
 

Attachments

  • 20230612_184119.jpg
    20230612_184119.jpg
    582.1 KB · Views: 86
  • 20230612_184554.jpg
    20230612_184554.jpg
    465.7 KB · Views: 91
  • 20230612_184550.jpg
    20230612_184550.jpg
    602.8 KB · Views: 82
  • 20230612_184517.jpg
    20230612_184517.jpg
    489.3 KB · Views: 86
  • 20230612_184501.jpg
    20230612_184501.jpg
    553.4 KB · Views: 86
  • 20230612_184322.jpg
    20230612_184322.jpg
    680.5 KB · Views: 81
  • 20230612_184309.jpg
    20230612_184309.jpg
    582.9 KB · Views: 82
  • 20230612_184240.jpg
    20230612_184240.jpg
    758 KB · Views: 91
  • 20230612_184224.jpg
    20230612_184224.jpg
    688.7 KB · Views: 84
  • 20230612_184135.jpg
    20230612_184135.jpg
    590.7 KB · Views: 82
Member
Joined 2012
Paid Member
Confused by your answers.

1. Question #1 is not a yes or no question. What does the R9 voltage do when you adjust the trimmer? What are the voltages if it changes? Max? Min?

2. So there is 0V at R9?

3. I meant Q1 drain, my mistake. Does voltage at Q1 drain change? Or stays at 0V?

Are you sure voltage at Q1 drain is 0V?
 
Last edited:
oh, I'm sorry, no voltage at all on R9 and nothing changes with the trimmer.
and yes no voltage on the drain of Q1. 0 volts with no change. I did not mention this but the drain did at one point range from 4 to 7 volts(with pot adjustment) then I reflowed then suddenly got 12 volts then I played it then it died now I'm here.

and no it's no broken the photo is dookie but in person, it's clear as day it's not damaged.
 
Member
Joined 2012
Paid Member
It seems things have gotten worse.

No voltage at R9 is a sign that the JFET, Q4, is not working. But 21V as measured previously was not good either. So it seems Q4 is bad.

No voltage Q1 drain is not good either, nor was previously measured 1.7V at R5/Q2 gate. So possibly Q2, and Q3, ZTX450, are also bad.

You can remove them and test them.

Also go over all of the wiring. Compare the good amp with the bad amp. Check and compare each wire and make sure that they are connected identically.
 
So I have just removed q1,q2,q3,q4. All of them seem to be working just fine according to
. All of them perform as they should according to their own spec sheets and D G S, B C E legs. I tested the diode load and the capacitance of the mosfets.

Something must be wrong with a capacitor or resistor?. or some type of short right? I'm looking at everything I did find that one resistor broke a piece off its outer blue paint shield color band thingy from trying to take it out(from earlier jumping to the conclusion it's the resistors because I didn't measure the resistance on all of them)but that wouldn't be it would it?

I should probably start removing and double-checking my caps and resistors right? because I've quadruple-checked my wires but ill check again.
 
It is .47 as I believe it should be. And no I just looked at all four, I have two of the 47 and 68 like I should so two pairs.

update: I am stumped guys I removed everything off the board and tested everything and seems to be fine. The larger caps measure 1154 and 2963 so I don't think they are the problem but still didn't find any shorts on the board. All the resistors were spot on according to their silk number on the PCB. the pot also moves smoothly through 0 to 4k+ohms. I also took a continuity check on the board and all the traces seem to be fine. I also did read 24v into V+ so I would imagine my wiring job is fine because it gives 24v as it should to the board so I am lost for words. I'll double-check everything and probably put it back together. If anyone has ideas thanks in advance.
 
Ahh then perhaps it is the way it is marked. My .47s both look identical and both have a clear decimal point before the 47. Like the one closest to the front of your picture and on the other side of the module that apparently works.

Will be curious to know what happens on reassembly.
 
update: I finished the bad side again I took my time and did the best soldering job I've ever done. I cleaned the board removed all the old solder and did overall a much cleaner job. I got 12v on Q1, and both sides warmed up evenly(the bad side would not heat up). tested it Bridged Mono XLR and it sounds and acts like the other amp that came out good. So I have no idea what might have happened but so far it seems like it's working. I guess like the other post have said, "90 percent of the time it is cold/bad/no solder".
Will play with it tomorrow I am itching for it and will update if anything goes wrong(again). Thanks guys for the help anyways.<3
 
  • Like
Reactions: 2 users