• WARNING: Tube/Valve amplifiers use potentially LETHAL HIGH VOLTAGES.
    Building, troubleshooting and testing of these amplifiers should only be
    performed by someone who is thoroughly familiar with
    the safety precautions around high voltages.

807 AB2 oscillation maybe?

Status
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.
Hi,

Sorry if this post is a bit brief but im at work.

i have designed an AB2 guitar amplifier using 807's ive tested all up till the 807 grids as working perfectly.
When i connect the 807 grids i get a waveform like the one in the picture attached.

It works fine up until about 20v peak to peak on the grids then increasing it further gives the distorted waveform and a whistley sound.
When the distortion occurs the neon shunt regulators on the screen of the 807's flicker like theyre drawing a lot of screen current?

HT is about 460V, bias is around -23v on the 807 grids giving 3V across their 47ohm anode resistors (64mA per tube), screens are nominally at 300V.

2*12ax7 gain stage => 12ax7 LTP => MOSFET fixed bias and drive using IRF820's => 807 grid.

Any ideas because im a little stumped so far?
 

Attachments

  • wave.jpg
    wave.jpg
    10.2 KB · Views: 434
Thanks for replies,
Ill draw up a schematic in about an hour, hopefully i can squeeze it into the picture size limit.. that always gives me grief.

I have no resistors on the screens i just have the voltage dropping resistor for the shunt which is 6K.
i.e. both screens are connected directly to the node which is between the top of the neon stack and one end of the 6K dropping resistor.

The bias is fixed by the mosfet drivers whose sources are retuned to an adjustable negative supply.
 
Heres schematic,

-supply for 12ax7's is 260V

-6L6 is actually 807

--sorry for dodgy symbols i had to whip it up fast

-from the phase inverter onwards i only drew one half of the output stage because it is identical.

-D3 and D2 represent VR150 regulators

-the inductors represent the output transformer primary

-D4 goes to 460v AC
 

Attachments

  • ampsimetrix2.png
    ampsimetrix2.png
    18.6 KB · Views: 480
Re: flickering VR tubes...could your B+ be sagging enough during transients to briefly fall below the necessary strike voltage for the tubes?(WAG)

It looks like you aren't employing grid stoppers. They may help prevent any oscillations.

Are you employing any global feedback?
 
Thats an interesting point, i havent checked the B+ when driving with signal. Ill look at it tonight.
I have got 300ohm stoppers on all the 12ax7's, and 1k on each mosfet gate, i read it is best not to put stoppers on the 807's in AB2 as the grids draw current and youd get a reduction in grid volts when going from AB1 to AB2 on the signal peaks?

Should i have one side of my OPT connected to the signal ground? at the moment the speaker and secondary are floating.
 
Craig405 said:


Should i have one side of my OPT connected to the signal ground? at the moment the speaker and secondary are floating.

You need to ground your OPT secondaries. I ground mine to the chassis at my PSU ground point. I'm surprised that you aren't getting any hum leaving them floating.

...a grid stopper may be a necessary evil if you are getting an oscillation.

...no feedback?
 
Ex-Moderator
Joined 2004
According to your schematic, you aren't using any grid stoppers. Those 300 ohm resistors (68k on the first stage) are in the wrong place to act as stoppers, they need to be between the grid resistor and the grid itself and soldered to the grid pin with a very short lead. I doubt very much if that would be the cause of your grief, though, since the 12AX7 has very low Gm.

If you're sharing the screen regulation between two tubes, then there is only 26.67mA available before the screen voltage will drop below 300v. Since each screen will draw approx. 10mA at full power, that leaves only 6.7mA for the VR tubes, which have a minumum current of 5mA. My guess would be that the VR tubes are dropping out of regulation at maximum power - which would make them flicker!

Try reducing R24 to 4.7k, allowing 34mA total current. That will be able to provide 10mA per screen and still have 14mA left over for the VR tubes. I don't know what the no-signal screen current would be but even if it dropped to zero, those VR150 tubes could handle the full 34mA OK (max is 40mA). While you're at it, add a screen stopper to each tube of 150 ohm, because parasitics there are a possibility.

Better than just using those puny VR tubes on their own, though, would be to amplify the regulation voltage with a source follower, using an IRF820.
 
Craig405 said:
Any ideas because im a little stumped so far?

Yeah. 807s are notorious for this. What you have there is a damped RF oscillation that's being triggered by plate current cutoff (Barkhausen oscillation). I had the same thing happen with a project that used 807s. What you need is a really good plate stopper, and screen stoppers.

In this design, the plate stoppers (L1, R31 & L2, R32) consist of ten turns of #18 wire; ID= 7/16"; space wound. Install 100R, 2W, C-comp resistors inside the coil. Install right at the plate connector. (If you can't get 100R / 2W C-comps, use four, 470R / 0.5W C-comps in parallel.)

Install 1K5 / 0.5W C-comp or C-film grid stoppers right at the screen grid connection at the socket.

This should get the final stable.

Main Schemo
 
Many thanks for replies.

Ray, you're right i have got the 1M resistors the wrong side of the 300R stoppers.
They are soldered straight to the pin though ill just have to shift the 1M to the other side. thanks for noticing that!
Ill look into my screen regulation, the HT sagged a bit morethan i expected and i knew the VR tubes would struggle a bit on signal peaks, i have one IRF820 left hehe, ill try and incorporate it as a pass device.

Miles thats a relief! Barkhausen criterion rings a bell from lectures last year.
the 1k5's will be a piece of cake to add, although the anode supressors might be a bit tougher, ive got wires trailing from the anodes outside my case so its going to be hard/messy to put them on the cap but if they have to be on the cap then ill do it :)
 
Craig405 said:
Miles thats a relief! Barkhausen criterion rings a bell from lectures last year.

To be technically accurate, Barkhausen Critierion is different from the Barkhausen Effect. The latter causes oscillation by means of a negative resistance characteristic that can arise when you have a positive screen grid, a positive plate, and a negative (or neutral) element between them. The usual method for preventing such "snivets" is a slight positive bias on the suppressors/beamformers. You will see this specified for certain types like the 813 or the 802. Being that the beam formers are internally connected to the cathode in the 807, this is not possible. Thus, the need for screen stoppers to break up the resonant path, and load it down so that the oscillation doesn't occur.

If you can't manage the plate stoppers, try screen stoppers first, make certain that you install them as close to the socket tabs as possible.
 
Well, that was cool.. Ive just been playing through this little beast and it sounds nice, plays loud and it distorts nicely too when overdriven.

Its still a bit marginal on the stability, i put in some 100ohm 3watt resistors i had (dunno if they're carbon but i guess so because they're really old)
And i soldered the 1k5's right on to the tabs of the screen.
It plays OK if i connect my DMM across one of the plate suppression resistors but if i remove it it oscillates :/.

The voltage regulators blink about when its sucking up the current and collapsing my supply a bit. Cant see how much the supply varies because i need the DMM on the anode resistor.

Ill get the proper resistors, some insulated wire and cut down my long anode leads as soon as i can.. hopefully this will make it stable.

sucess!
 
Well its much better now with 2x 47ohm carbon resistors in series with 10 turns of 18awg wire wrapped around them per anode.
Also 1k6 carbon on each screen grid right on the pin.

It will still oscillate when grids are given a signal of 60vpk-pk@500hz

And It oscillates when grids are given signal of 40vpk-pk @20khz

(i only tested at these 2 frequencies).

I can think of 4 options but dont know which is best, if any;
1)-increase screen resistor value,
2)-increase number of turns on anode resistors,
3)-solder anode resistors straight to the anode topcaps (not the actual tube topcaps).
4)-try a different pair of 807's.
Where is a good place to begin?

I also need to add some resistance to the 807 cathode to watch the bias now my anode resistors are bypassed with inductors. maybe 10 ohms or so will do.
 
Woa there.. i may have misinterpreted the data sheet and have run these tubes way too hard.

RCA data sheet specifies that with HT of 500V idle current for 2 tubes is ---60mA---
Ive been biasing 60mA per tube! so 120mA!

Have i made a big mistake here!? should i back bias down to 30mA per tube for AB2.
It pains me to think i have tortured the poor tubes :(
 
Status
This old topic is closed. If you want to reopen this topic, contact a moderator using the "Report Post" button.