ICEpower 1000ASP+500A - diyAudio
Go Back   Home > Forums > Wiki

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Default

ICEpower 1000ASP+500A

Is there anybody out there that had tried to drive an ICEpower module 500A powered with a 1000ASP module for a stereo amplifier setup?
Looking at the data sheets there are some differences except from the power output. But is it notable in the real world?
The 500A is not short protected at the output. Is there anyone that had made any protection that is working? I guess that itís not protected even it is powered with the 1000ASP.


Contributors: lydlaug, dfidler
Created by lydlaug, 24th January 2010 at 11:46 AM
Last edited by dfidler, 14th August 2010 at 08:20 PM
Last comment by dfidler on 6th August 2010 at 08:10 PM
1 Comments, 2,426 Views
Page Tools
Search this Page


Posting Rules
You may not create new articles
You may not edit articles
You may not protect articles

You may not post comments
You may not post attachments
You may not edit your comments

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off
Hide this!Advertise here!

New To Site? Need Help?

All times are GMT. The time now is 10:03 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2