USB to I2S 384Khz - DSD Converter - Page 142 - diyAudio
Go Back   Home > Forums > Commercial Sector > Vendor Forums > Vendor's Bazaar

Vendor's Bazaar Commercial Vendors large & small hawking their wares

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th March 2013, 01:29 PM   #1411
diyAudio Member
 
Join Date: Apr 2011
Hi ,
I bought Amanero a few months ago.
I m running Vortexbox > amanero > buffalo III

When playing music with different sampling rate, sometimes the DAC don't get the sample rate change and starts playing music faster, and ugly.

I need to pause the vortexbox player and press play again and then it gets the right sample rate.

Anyone solved this issue?
Thanks
  Reply With Quote
Old 30th March 2013, 09:41 AM   #1412
diyAudio Member
 
Join Date: Jan 2011
Location: Madrid - Spain
Quote:
Originally Posted by glt View Post
Should work with two masters talking to one server as long is the I2C is released after each use (which it should). You could try starting it without the on-board processor (certain things will be configured differently, but I2S or SDPFI should work) and try the mute/unmute...
I went back to firmware 1069 (CPU only) using tool 110a and removed firmware chip and it worked fine.

For verifying I used:

On352Set
ADD: 0x48
REG: 0x0A
VAL: 0XCF

On44Set
ADD: 0x48
REG: 0x0A
VAL: 0XCE


Played a 352K track and output was muted then played a 44.1K track and it unmuted output.

It doesn't work with the firmware chip on the Buffalo though, all non default configs it provides would have to be assigned to an event though I don't know which one could be the optimal one.

There is something affecting firmware 1072 and the Buffalo's compatibility.
  Reply With Quote
Old 30th March 2013, 12:37 PM   #1413
diyAudio Member
 
merlin el mago's Avatar
 
Join Date: Sep 2009
Location: Catalonia - Europe
Quote:
Originally Posted by Jackal29a View Post
I went back to firmware 1069 (CPU only) using tool 110a and removed firmware chip and it worked fine.

For verifying I used:

On352Set
ADD: 0x48
REG: 0x0A
VAL: 0XCF

On44Set
ADD: 0x48
REG: 0x0A
VAL: 0XCE


Played a 352K track and output was muted then played a 44.1K track and it unmuted output.

It doesn't work with the firmware chip on the Buffalo though, all non default configs it provides would have to be assigned to an event though I don't know which one could be the optimal one.

There is something affecting firmware 1072 and the Buffalo's compatibility.
Congratulations
  Reply With Quote
Old 30th March 2013, 04:01 PM   #1414
Marek is offline Marek  Poland
diyAudio Member
 
Join Date: Apr 2003
Location: Katowice
1072 firmware has increased I2C clock speed to 100kHz. Speed isn't a problem here because my atmega8 configured to send I2C commands as a master is working flawessly with Buffalo at 100kHz.
There is some unclear problem with Amanero I2C functionality - for example it was working to me for a while with 1069 firmware, then I upgraded to 1072 (not working) and back to 1069 and now it is not working... This is not just firmware related or OEMTool related - I can't figure out what is the reason

Last edited by Marek; 30th March 2013 at 04:04 PM.
  Reply With Quote
Old 30th March 2013, 05:02 PM   #1415
glt is offline glt  United States
diyAudio Member
 
Join Date: Oct 2004
Quote:
Originally Posted by Jackal29a View Post
I went back to firmware 1069 (CPU only) using tool 110a and removed firmware chip and it worked fine.

For verifying I used:

On352Set
ADD: 0x48
REG: 0x0A
VAL: 0XCF

On44Set
ADD: 0x48
REG: 0x0A
VAL: 0XCE


Played a 352K track and output was muted then played a 44.1K track and it unmuted output.

It doesn't work with the firmware chip on the Buffalo though, all non default configs it provides would have to be assigned to an event though I don't know which one could be the optimal one.

There is something affecting firmware 1072 and the Buffalo's compatibility.
Yes, congrats!. If the other master does not release the bus, then no one else can acquire the bus. But you will need to capture the bus signal to see if this is what is going on.
__________________
www.hifiduino.wordpress.com
  Reply With Quote
Old 30th March 2013, 05:40 PM   #1416
diyAudio Member
 
Join Date: Jan 2011
Location: Madrid - Spain
Quote:
Originally Posted by glt View Post
Yes, congrats!. If the other master does not release the bus, then no one else can acquire the bus. But you will need to capture the bus signal to see if this is what is going on.
I wish I knew how or have the tools to do that but even if I did and found the problem, how could I fix ? probably new firmware code from TPA would be needed and I highly doubt they'll be willing to write it as they already state that the chip needs to be removed if an external uC is used.
  Reply With Quote
Old 30th March 2013, 06:55 PM   #1417
diyAudio Member
 
Join Date: Jun 2004
Location: Bath, UK
Jackel29a - do you have a scope to examine the I2C lines?
  Reply With Quote
Old 30th March 2013, 07:02 PM   #1418
diyAudio Member
 
Join Date: Jan 2011
Location: Madrid - Spain
Unfortunately I don't.
At least there is a possible workaround by chaining I2C commands to set the default config and assigning them to a non frequently used event like On384Set. One just needs to play a purpose created file every time the DAC is turned on. Or maybe use OnReset?
  Reply With Quote
Old 2nd April 2013, 04:20 PM   #1419
Nikitas is offline Nikitas  Greece
diyAudio Member
 
Join Date: Nov 2011
Location: Amsterdam
Guys, does the amanero need separate power supply? Or is it fed through the laptor's usb line?
  Reply With Quote
Old 2nd April 2013, 06:23 PM   #1420
diyAudio Member
 
merlin el mago's Avatar
 
Join Date: Sep 2009
Location: Catalonia - Europe
Is bus powered but you can take off the LDO and supply with a separate PSU.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HLLY USB SPDIF/ I2S CONVERTER kp93300 Digital Source 12 29th January 2012 02:55 PM
exaU2I - 32bit/384kHz Multi-Channel Asynchronous USB to I2S Interface exa065 exaDevices 0 11th November 2011 11:41 AM
$40 USB to I2S converter sharpi31 Digital Line Level 7 12th July 2009 04:09 PM


New To Site? Need Help?

All times are GMT. The time now is 02:25 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2