hypex ncore - Page 200 - diyAudio
Go Back   Home > Forums > Commercial Sector > Vendor Forums > Vendor's Bazaar

Vendor's Bazaar Commercial Vendors large & small hawking their wares

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th February 2012, 10:49 AM   #1991
diyAudio Member
 
john dozier's Avatar
 
Join Date: Dec 2010
Location: columbia sc
There is a very good reason why the word "foolproof" contains the word FOOL! Regards
__________________
Evil looms. Cowboy up. Kill it. Get Paid.
  Reply With Quote
Old 10th February 2012, 10:58 AM   #1992
diyAudio Member
 
Join Date: Apr 2004
Location: BE/NL/RW/ZA
Quote:
Originally Posted by ChrisPa View Post
Any idea when that might hit your production batches?
Considering that the current batch has sold out it's likely going to be the next.
__________________
There's a time for everything, and this is not it.
  Reply With Quote
Old 10th February 2012, 11:07 AM   #1993
jtwrace is offline jtwrace  United States
diyAudio Member
 
jtwrace's Avatar
 
Join Date: Jan 2007
Location: NC
What is the ideal enclosure size from a technical standpoint?
__________________
"Science is not a democracy"- Earl Geddes, Ph.D.
  Reply With Quote
Old 10th February 2012, 11:12 AM   #1994
3lviz is offline 3lviz  Finland
diyAudio Member
 
Join Date: May 2009
So as long as I keep the SMPS and the amplifier connected, the 10 minute rule mentioned in the manual applies? If that is the case wouldn't it be wise to mention it in the SMPS600 manual for the current revision of the power supply? Not all know this and not all read this forum and some may miss piece of information. And in the future the SMPS600 boards might change owner and the new owner may be do not know this and might hurt himself.

Last edited by 3lviz; 10th February 2012 at 11:21 AM.
  Reply With Quote
Old 10th February 2012, 11:16 AM   #1995
diyAudio Member
 
Join Date: Apr 2004
Location: BE/NL/RW/ZA
The "10 minute rule" (or the requirement that you discharge the caps) only applies when somehow the supply was powered up without the amp attached. If you just wire them up before powering up there's no rule.

When someone builds a regular linear amplifier and one tests the supply without the amp, I should think it normal for them to discharge the caps before continuing as well. What's so mysterious about it?

Another item I'd like to add is that when you draw sparks when plugging the connector in, you're also seriously damaging the connector which isn't engineered for this. You need quite special terminal materials and plating for that. There's no way you can design around that. I can probably prevent the module from becoming unoperable after an accidental hot-plug but I can't possibly prevent all damage. So I will have the manual updated to reflect this.
__________________
There's a time for everything, and this is not it.

Last edited by Bruno Putzeys; 10th February 2012 at 11:27 AM.
  Reply With Quote
Old 10th February 2012, 11:39 AM   #1996
3lviz is offline 3lviz  Finland
diyAudio Member
 
Join Date: May 2009
I am just trying to clear out things, so nobody gets hurt or in worst case accidently dies just because he did everything mentioned in the manual, but didn't do something not mentioned there, such as discharge the power supply, which is procedure apparently known by "every" DIYer except me and not mentioned anywhere. My sole purpose of finding out how to exactly handle the SMPS600 without dying. Nothing more.

I thought the 10 minute rule also applied when the SMPS600 is connected to nc400 module. So, that is not the case and that is now cleared out.

Last edited by 3lviz; 10th February 2012 at 11:50 AM.
  Reply With Quote
Old 10th February 2012, 12:04 PM   #1997
ChrisPa is offline ChrisPa  United Kingdom
diyAudio Member
 
Join Date: Jan 2005
Location: Saddleworth
Quote:
Originally Posted by Bruno Putzeys View Post
I can probably prevent the module from becoming unoperable after an accidental hot-plug but I can't possibly prevent all damage.
Totally agreed and understood
  Reply With Quote
Old 10th February 2012, 12:05 PM   #1998
diyAudio Member
 
Join Date: Apr 2004
Location: BE/NL/RW/ZA
Quote:
Originally Posted by 3lviz View Post
I am just trying to clear out things, so nobody gets hurt or in worst case accidently dies
Ah sorry I thought you were referring to the amp plugging discussion (others were). Yes as far as the primary capacitor is concerned, indeed you should wait sufficiently long before touching any part of the primary circuit. That is a matter of personal safety.
__________________
There's a time for everything, and this is not it.
  Reply With Quote
Old 10th February 2012, 12:17 PM   #1999
diyAudio Member
 
Join Date: Mar 2009
Quote:
Originally Posted by mr_push_pull View Post
no report after 9 hours...
now is there a possibility that all NCORE owners are abducted by aliens? it would explain a lot of things.
Sorry for the delay in getting my review up. I was only able to listen for a few minutes last night by the time I got the ncores installed in my main system. One module had a loose cap which was causing noise at idle and it took me awhile to troubleshoot. I will be able to do some extended listening today and get a post up. My initial impressions are extremely positive.
  Reply With Quote
Old 10th February 2012, 12:29 PM   #2000
diyAudio Member
 
Join Date: Dec 2011
Quote:
Originally Posted by earflappin View Post
Sorry for the delay in getting my review up. I was only able to listen for a few minutes last night by the time I got the ncores installed in my main system. One module had a loose cap which was causing noise at idle and it took me awhile to troubleshoot. I will be able to do some extended listening today and get a post up. My initial impressions are extremely positive.
Someone is casting voodoo to the ncore release ...
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hypex problem, who can help Hansms Class D 9 18th August 2013 06:49 AM
Hypex steveww Class D 14 18th November 2010 01:44 PM
Question for those who have tried hypex smps with hypex modules avian Class D 12 3rd March 2009 09:30 AM
Hypex UcD 180AD + signal wires, Power Supply ST, Hypex Transformer TR100A c10h12n2 Swap Meet 7 7th July 2007 03:55 PM
FS: Hypex UcD 400/180AD, hypex toroid Archmage Swap Meet 4 14th November 2006 04:23 AM


New To Site? Need Help?

All times are GMT. The time now is 05:30 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2