New tubes in Velleman K4040 - diyAudio
Go Back   Home > Forums > Commercial Sector > Vendor Forums > Vendor's Bazaar

Vendor's Bazaar Commercial Vendors large & small hawking their wares

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th February 2008, 06:33 PM   #1
diyAudio Member
 
Join Date: Feb 2008
Default New tubes in Velleman K4040

I replaced the stock EL34 by a set of 6P3S (Russian type 6L6) and adjusted the bias to 36mV. Sounds good, but should I do more such as adjusting grid voltage? Thanxx, Maarten
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Velleman K4040 Brap Tubes / Valves 17 20th October 2011 09:56 PM
Velleman K4040 tube amp user feedback sought gjo Tubes / Valves 9 23rd January 2010 09:52 AM
Velleman K4040 conversion from EL34's to KT88's GeorgeK Tubes / Valves 6 8th February 2009 07:12 PM
Velleman K4040 is Always Blowing Output Tubes GeorgeK Tubes / Valves 24 29th August 2006 04:27 PM
Velleman K4040 (TDA 1514) amp problems MrSensitive Chip Amps 4 25th May 2005 01:08 PM


New To Site? Need Help?

All times are GMT. The time now is 02:58 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2