DSD512 on Buffalo IIIse - diyAudio
Go Back   Home > Forums > Commercial Sector > Manufacturers > Twisted Pear
Home Forums Rules Articles diyAudio Store Gallery Wiki Blogs Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Twisted Pear Superior quality electronic kits

Reply
 
Thread Tools Search this Thread
Old 17th July 2016, 11:32 AM   #1
diyAudio Member
 
nautibuoy's Avatar
 
Join Date: Jan 2010
Location: Somerset, England
Default DSD512 on Buffalo IIIse

Russ, over on the Botic thread we (twluke, miero and I) have been making good progress with getting a BBB running as a boticized Network Audio Appliance (NAA) for use with HQPlayer (HQP). In so doing, we've been experimenting with HQP's upsampling and have found the BBB/Botic is capable of PCM at up to 384KHz. It is also capable of up to Octa-rate DSD (DSD512) - almost!

twluke and I are both using Buffalo IIIse DACs.

With DSD512 we are experiencing short bursts of a static-like noise, which then fades away. This is maybe a good point at which to pick up the story:

Support for Botic Linux driver

Do you have any thoughts about what is going on?

TIA

Ray
  Reply With Quote
Old 17th July 2016, 01:20 PM   #2
miero is offline miero  Czech Republic
diyAudio Member
 
Join Date: Jun 2011
Location: Prague
Does the Amanero play DSD512 well with Cronus+B3?
__________________
BeagleBone Black with I2S, DSD and SPDIF interface (Linux driver)
http://bbb.ieero.com/
  Reply With Quote
Old 17th July 2016, 01:22 PM   #3
diyAudio Member
 
nautibuoy's Avatar
 
Join Date: Jan 2010
Location: Somerset, England
Yes, when the static noise has faded away it sounds good.
  Reply With Quote
Old 18th July 2016, 10:37 PM   #4
diyAudio Member
 
BrianDonegan's Avatar
 
Join Date: Dec 2004
Location: TPA HQ (The Basement)
You are experiencing the noise with both the BBB and the Amanero?

Try checking local supply (Trident) voltage when you are hearing the noise. Higher bandwidth music demands more current, which *might* be causing a voltage sag.
  Reply With Quote
Old 18th July 2016, 10:45 PM   #5
diyAudio Member
 
nautibuoy's Avatar
 
Join Date: Jan 2010
Location: Somerset, England
Thanks Brian.

I'm not using Amanero at all, just BBB.

Just to ensure clarity, twluke is using hermes/cronus with his BBB whereas I'm using brand X isolator/reclocker. We're both using B3SE and we're both getting the same symptoms.

I'll see if I can monitor the trident output voltages.

Last edited by nautibuoy; 18th July 2016 at 10:49 PM.
  Reply With Quote
Old 18th July 2016, 11:24 PM   #6
twluke is offline twluke  Japan
diyAudio Member
 
Join Date: Nov 2012
Location: Tokyo
Quote:
Originally Posted by BrianDonegan View Post
You are experiencing the noise with both the BBB and the Amanero?

Try checking local supply (Trident) voltage when you are hearing the noise. Higher bandwidth music demands more current, which *might* be causing a voltage sag.
Thank you for this info. I'll check it later tonight.
  Reply With Quote
Old 19th July 2016, 01:06 PM   #7
twluke is offline twluke  Japan
diyAudio Member
 
Join Date: Nov 2012
Location: Tokyo
Quote:
Originally Posted by BrianDonegan View Post
You are experiencing the noise with both the BBB and the Amanero?

Try checking local supply (Trident) voltage when you are hearing the noise. Higher bandwidth music demands more current, which *might* be causing a voltage sag.
I checked the supply voltage of trident when playing DSD512 via each of (a) BBB/Hermes/Cronus with noisy condition and (b) a prototype of BBB/Botic system with no audible noise. The CCS on Placid HD supplying trident was 720mA (= 720mV). The results are as follows:

VDD/VDD_XO/DVCC
(a) 3.2/3.2/1.1
(b) 3.2/3.2/1.1

I tried the CCS up to 850mA but the situation of noise from Hermes/Cronus remained unchanged. So I made the CCS back to the origina vlaue.

In summary it may be possible to say that the current noise issue is not relevant to the trident voltage sag.

Regards,
  Reply With Quote
Old 22nd July 2016, 08:30 AM   #8
diyAudio Member
 
nautibuoy's Avatar
 
Join Date: Jan 2010
Location: Somerset, England
I have it from a good authority that the Sabre position is the ES9018 doesn't support DSD512, for that the ES9038 is required.
  Reply With Quote
Old 22nd July 2016, 01:56 PM   #9
diyAudio Member
 
Russ White's Avatar
 
Join Date: Jan 2005
Location: Nashville, TN, USA
Send a message via Yahoo to Russ White
Make sure the SPDIF autodetect feature of the ES9018 is turned off - it can cause all sorts of problems with DSD.

Also at those rates wiring will be extremely critical.

Also be sure you are using the latest (available on github) on-board firmware especially if you run sync mode.

https://github.com/russwyte/Buffalo-...board-firmware
__________________
Less pulp more juice Twisted Pear Audio.
  Reply With Quote
Old 22nd July 2016, 05:38 PM   #10
diyAudio Member
 
nautibuoy's Avatar
 
Join Date: Jan 2010
Location: Somerset, England
Thanks Russ. I've turned off spdif autodetect and, fingers-crossed, so far after about 30mins of listening at 22MHz DSD I haven't experienced the static noise.

Checking the B3SE integration guide for the spdif setting I was reminded of the IIF bandwidth options and have been experimenting with them; I think I marginally prefer the 70KHz setting to the previous 'Normal' setting but will experiment further over the weekend.

I need to work out how to update the firmware next.

Ray

NB. Should have said that all of the wiring is via short ufl cables.

Last edited by nautibuoy; 22nd July 2016 at 05:56 PM. Reason: Added note.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB : Buffalo III or Buffalo IIIse pw8888 Swap Meet 0 29th March 2015 10:06 PM
Arduino Code for Buffalo IIISE neskor Digital Line Level 0 22nd June 2014 12:35 PM
WT Buffalo-IIISE nicusim Swap Meet 2 8th December 2013 10:39 PM
My new Buffalo IIISE dac needs the best! Vingborg Digital Line Level 1 15th September 2013 08:04 PM
WTB: Buffalo IIIse DAC igbee Swap Meet 0 31st July 2013 04:09 PM


New To Site? Need Help?

All times are GMT. The time now is 12:02 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright 1999-2017 diyAudio

Content Relevant URLs by vBSEO 3.3.2
Wiki