Go Back   Home > Forums > Commercial Sector > Manufacturers > Twisted Pear

Twisted Pear Superior quality electronic kits

Reply
 
Thread Tools Search this Thread
Old 16th November 2010, 02:47 PM   #1
steveww is offline steveww  United Kingdom
diyAudio Member
 
Join Date: Jan 2007
Location: Northamptonshire
Default Placid Stability

I have a Placid BP that works fine on the +rail be the - rail starts at 15V then looses 0.1V every couple of seconds finally bottoming out at around 9V.

From then on tweaking the adjustment pot makes no difference.

Any idea why?
  Reply With Quote
Old 16th November 2010, 04:59 PM   #2
steveww is offline steveww  United Kingdom
diyAudio Member
 
Join Date: Jan 2007
Location: Northamptonshire
Something had definitely died as the voltage across VR3 varies with its ohm value. AFAIK this should match Vref at around 4V.

May be a transistor or one channel of the opamp has died.

Any ideas how to test for which?
  Reply With Quote
Old 17th November 2010, 12:18 PM   #3
diyAudio Member
 
Russ White's Avatar
 
Join Date: Jan 2005
Location: Nashville, TN, USA
Send a message via Yahoo to Russ White
Usually this is a transposed component. Look for transistors that may be swapped.

Also are the LED lighting correctly?

Continue this on the support forum with pictures if possible. Thanks.
__________________
Less pulp more juice Twisted Pear Audio.
  Reply With Quote
Old 19th November 2010, 07:25 PM   #4
diyAudio Member
 
Bassivus's Avatar
 
Join Date: Aug 2004
Location: Novi Sad, Vojvodina
Quote:
Originally Posted by steveww View Post
I have a Placid BP that works fine on the +rail be the - rail starts at 15V then looses 0.1V every couple of seconds finally bottoming out at around 9V.

From then on tweaking the adjustment pot makes no difference.

Any idea why?
I have had very similar thing with mine...

I just tapped on the trimpot few times with my index finger and ever since all is fine
__________________
...is I disappear. There is ONLY the music.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Placid-BP Bipolar Shunt Regulated Power Supply Russ White Twisted Pear 189 11th December 2013 11:56 PM
FS: Twisted Pear Placid PS Version 2.0 merlin el mago Swap Meet 5 30th May 2010 06:51 PM
FS Twisted Pear Placid BP shunt regulator merlin el mago Swap Meet 8 1st April 2010 11:17 AM
Twisted Pear Buffalo 32S / Placid Shunt PS Crafty Swap Meet 1 18th February 2010 12:06 PM
WTB: Placid or other high quality power supply for Buffalo 32s 1.1 nicksgem10s Swap Meet 0 10th January 2010 11:52 PM


New To Site? Need Help?

All times are GMT. The time now is 02:55 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2