diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Tubes / Valves (http://www.diyaudio.com/forums/tubes-valves/)
-   -   Audible Illusions Modulus faulty? (http://www.diyaudio.com/forums/tubes-valves/94064-audible-illusions-modulus-faulty.html)

st2_998 12th January 2007 10:44 PM

Audible Illusions Modulus faulty?
 
Two months ago I bought an Audible Illusions Modulus 2A. I soon emailed the manufacturer in order to get user manual and schematics, they answered me once, then total silence for 25 days. My mails are relayed but simply no answer. :whazzat:
Does anybody have documentation on this preamp?

That's why I'm worried. The preamp has a relay (warm-up?) clicking one minute after power-up. There's also a LED which, in the first days, used to light up just at relay's click. Now the relay is clicking normally and the preamp is usable at once, but the LED comes up only 15-20 minutes later! Is that a hint for a fault?
Thanks to anybody taking the time to drop a line!

st2_998 13th January 2007 09:49 PM

............................ :(

st2_998 15th January 2007 10:48 PM

Funny
I thought there were at least a few people that own these...
I have to say that A.I.'s silence is also very sad... :apathic:

redrabbit 25th August 2007 05:29 AM

Do you still have the problem?

I had a similar problem with my 2D.
Turns out there is a resistor that senses the powerline voltage that triggers the relay. If your wall power is too low by a few volts, the relay won't trip.
Mine was serviced years ago.
All they did was to put a jumper across one resistor.
Simple.

=RR=

st2_998 25th August 2007 02:20 PM

In fact, after posting I managed to question a hard-to-reach AI technician, who warned me against low voltage mains. It's funny, because relay triggers fine, but only LED stays unlit for some time, then lights up eventually. Apart form the LED the unit is working flawlessly (I only had to change the pots, rigging up a stereo TKD 602). I've had a dear friend's Dynaco MK IIIs at home for some time, and they work great together.
Thanks for your reply!


All times are GMT. The time now is 10:54 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2