hum - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th August 2006, 03:18 PM   #1
LuisMCP is offline LuisMCP  Spain
diyAudio Member
 
LuisMCP's Avatar
 
Join Date: Jun 2001
Location: Madrid, Spain
Default hum

Hi all,

I have some problems with hum in a tube amp.

Hum is bigger when I turn volume pot to max volume, and when I plug a source in the RCAs input.

Hum is always seen as a 100 Hz signal in scope.

Ripple in PSU output is small, about 6V peak to peak.

Some help is welcome.

regards,

luis.
Attached Files
File Type: pdf earthing.pdf (22.0 KB, 118 views)
  Reply With Quote
Old 9th August 2006, 05:06 PM   #2
Sherman is offline Sherman  United States
diyAudio Member
 
Join Date: Feb 2004
Location: Chicago area
Sounds to me like diode noise (twice the 50Hz mains frequency). Also in my opinion 6V ripple is very high. I like something in the mV range.

Bottom line- I believe you need to make sure the rectifier(s) are well away from any signal lines and you need more filtering on the B+.

Edit:- I would also move the filament CT from your signal ground to the chassis ground.
__________________
--Sherman
  Reply With Quote
Old 9th August 2006, 05:35 PM   #3
Jeb-D. is offline Jeb-D.  United States
diyAudio Member
 
Jeb-D.'s Avatar
 
Join Date: Nov 2005
Location: SoCal
As stated, 6Vp-p is pretty high and will definatlely be audible at the output, If that ripple is supplying any passive or reactive loaded, single ended stages.
  Reply With Quote
Old 9th August 2006, 06:28 PM   #4
Jeb-D. is offline Jeb-D.  United States
diyAudio Member
 
Jeb-D.'s Avatar
 
Join Date: Nov 2005
Location: SoCal
Regarding your diagram It seems like it would work ok, but there are a few things I want to point out. To each his own, but this is just food for thought.

1) The heater center tap should have it's own line to the star ground, instead of being referenced to the input's ground.

2) How the volume control is setup is common for a guitars volume control. However; for an amp, the signal should be fed to the end of the pot(opposite end of ground, obviously) rather then the center. Then use the center to go to the input tubes grid. This workes like a voltage divider and prevents the signal source from being loaded down at low volumes. Also, the pot's ground should be connected to the ground of the input tube rather than at the star/power supply.

3) Your amps basically grounded at the star point. This is fine when using a signal source that is not referenced to ground(like a CD player) , but if the source is grounded(like a computer) you may get a ground loop. If you have a ground loop problem when using a grounded source, you hack the ground connectors off the RCA plugs at one end. Leave one end in tackt though so the shield in the cable is grounded still. Just you don't want to connect the two grounds. It's best to reference ground at the input rather than the star point. Though sometimes, it is difficult to do without causing ground loops, when using a single power transformer for a stereo amp, such as your case.

4) Also, it appears it already is, but in your setup, the input jacks should be isolated from the chassis. And referenced to ground through the cable sheild. If it's not isolated from the chassis and is also grounded through the cable that would cause another ground loop.

You may already get this concept, but it took me a while to figure out(im slow). Current returns to the transformer winding, ground is just for voltage reference. Once I figured this out, It helped me alot when coming up with grounding schemes.
  Reply With Quote
Old 9th August 2006, 09:23 PM   #5
bembel is offline bembel  Europe
diyAudio Member
 
bembel's Avatar
 
Join Date: Aug 2006
Send a message via Yahoo to bembel
Hi, to me 6Vpp is a lot too !
Jed's remarks are very pertinent (is your CD player three or two connectors plug to mains ? ----> ground loops)
Have a look at this, it may be helpfull ---> http://www.tone-lizard.com/High_Resistance_Ground.htm
Do you see any difference tightening inputs/outputs cables together? (thus reducing ground loops on interstages cables)

Hope it may help.
__________________
Plus je pédale moins vite, moins j'avance plus vite !
  Reply With Quote
Old 9th August 2006, 10:40 PM   #6
LuisMCP is offline LuisMCP  Spain
diyAudio Member
 
LuisMCP's Avatar
 
Join Date: Jun 2001
Location: Madrid, Spain
Thanks a lot.

Sorry, I forget to say that is a PP amp with EL34 in UL configuration (30 watts)
PSU have 4 x 47 uF MKP caps (Mundorf Tubecap).

I have replacing CT-heaters to chassis ground and hum remains the same, but replacing RCAs GND or POT-GND are a huge difference.

I have 2.5 mV (rms) of noise at L channel, and 6.5 mV (rms) at R channel, L channel being almost inaudible now, and volume pot are no problem with noise.


I will try to add a 200 uF (electrolytic) cap to PSU (total 400 uF) and last with a total of 800 uF.

I will try different points to tie RCAs and POT-GND to ground in next days. I will be happy with only 1 mV of noise.

regards,

Luis.
  Reply With Quote
Old 10th August 2006, 02:24 AM   #7
diyAudio Member
 
Join Date: May 2005
Location: California
Make sure your rectifiers are good also. In a push pull amp even 100uf in the power supply is more than enough to get the hum down into the mv range, so I don't think adding more uf will help much. Check the diodes to make sure they aren't passing AC.
Daniel
  Reply With Quote
Old 10th August 2006, 02:27 AM   #8
diyAudio Member
 
Join Date: May 2005
Location: California
Thinking about it some more, I would thnk your problem lies with a ground loop. Usually hum doesn't increase that much when the volume is turned up with a power supply problem; it's VERY loud all the time!
Daniel
  Reply With Quote
Old 10th August 2006, 03:13 AM   #9
diyAudio Member
 
rwellerson's Avatar
 
Join Date: Nov 2005
Location: BH - Brazil
Hi Luis

Try this: from B+ make a voltage divider to get around 40 to 45 V.
Place 1 microF x 250V poliester from this point (40~45V) to ground.
Connect that point to the CT of the heaters (and of course disconnect the CT from ground...)

And say good bye to hum.... (well: in 99% of excessive hum instances it will be gone...)
And it doesn't hurt to use DC for the heaters' supply to the input stages....

Buenas sortes
Ricardo
  Reply With Quote
Old 10th August 2006, 04:45 AM   #10
diyAudio Member
 
sorenj07's Avatar
 
Join Date: May 2006
I can testify to making a simulated center-tap on the filament lines. I had a preamp with a simulated hum of less than 1mV that hummed very loudly, then Sharon over at DiyTube referenced the filament to ground with a couple 1k 1/2 watt resistors and it's very quiet.

You will probably be happy with a bit more than 1mV of noise, I don't know for sure but pretty much anything under a volt or maybe 1/2 a volt for the plate is quite good for a power amp. One other thing I've heard of that you could try is "lifting" signal ground, i.e. making a separate star point for all non-PSU grounds, and connecting that to the PSU ground and chassis with a 10-ohm resistor. Making the signal ground "less negative" than power ground should block out hum from the PSU, or so I've read. I'm going to try it in the amp I'm building, so check back in a couple weeks, a month at most, to see
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



New To Site? Need Help?

All times are GMT. The time now is 11:45 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2