How to Build Unbilical from PS to Phono - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th May 2006, 09:32 PM   #1
diyAudio Member
 
Join Date: Apr 2006
Location: Toronto
Default How to Build Unbilical from PS to Phono

I'm finishing my SE tubed phono. Its actually K&K audio Phono boards but with a separated detached off unit power supply located 2+ft away.

How should I phsycially build the umbilical cable between the PS and the phono?

The connections between the PS and phono are B+ (at ~210VDC) the B+ return, filament+, filament- (filament is DC) and a ground wire that runs from the PS chassis to the phono chassis.

I'm thinking to do the following:

Use a sheilded piece of interconnect for the filament + and filament-, use a twisted pair (without shield) for B+ and B+ return. Then lay these wires and the chassis ground wire side by side and envelope with a piece of plastic mesh braid.

Make sense? good idea, bad idea? Would you do some other way, possible braid or twist them all together? Should I also shield the B+ and its return together ?
  Reply With Quote
Old 29th May 2006, 01:09 PM   #2
SY is offline SY  United States
diyAudio Moderator
 
SY's Avatar
 
Join Date: Oct 2002
Location: Chicagoland
Blog Entries: 1
If you set things up so that you've got a reasonably quiet raw supply, then add filtering/regulation on the preamp end, the criticality of that umbilical goes away. Mine is just braided all together and the preamp is dead quiet.
__________________
And while they may not be as strong as apes, don't lock eyes with 'em, don't do it. Puts 'em on edge. They might go into berzerker mode; come at you like a whirling dervish, all fists and elbows.
  Reply With Quote
Old 30th May 2006, 02:06 AM   #3
diyAudio Member
 
Kofi Annan's Avatar
 
Join Date: Jan 2004
Location: US
I have an off-board supply for my phono pre and I used Speak-on cables for the connection. Works fine and it's dead quiet.

Kofi
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY phono to replace roksan phono stage seroxatmad Analog Line Level 6 14th December 2008 06:46 PM
new phono stage or old preamp with phono? flohmann Analog Line Level 2 2nd October 2008 10:51 PM
how build usb phono pre riaa tekton364 Analogue Source 2 28th September 2007 09:50 PM
Phono transformer VS Active phono pre ckwong99 Analogue Source 0 2nd November 2005 05:35 AM


New To Site? Need Help?

All times are GMT. The time now is 06:08 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2