Leak Stereo 20 questions - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 15th April 2006, 12:01 PM   #1
diyAudio Member
 
Join Date: May 2005
Location: Pretoria, South Africa
Default Leak Stereo 20 questions

Hi All,

I am refurbishing a Leak Stereo 20 for someone, and have a few questions.

1. More than one circuit diagram (component, valuewise) appear to exist. The amp in my possession seems to have several changes not listed on any diagram. These components appear to be the original as mounted in the factory. (At this stage I must apologise for not succeeding in copying the diagram onto this post. I will refer to component designations as per the diagram mostly found.)

2. My main problem is that R5, indicated as 100K on the diagram has been lowered to 47K in the amp. With the indicated cathode resistor of R3 (2K2), the input triode works at a rather starved point on the Ip/Vp curves, giving at least 2x the distortion it would have with R5 = 100K. (The plate signal swing is very low, but still; preferred R3 for R5=47K would be 1K2.) Can anybody recall having seen R5 as 47K on any mod?

3. Going to R3=100K increases the loop gain by some 1,7x, bringing the amp on the verge of instability with a then feedback factor of 25 dB. For this one can lower R4 (100R) but that moves it away from the original again. What was the position?

4. In my amp C5 = 100nF, but the diagram indicates 20nF. This presumably for some stability improvement at low frequencies (which would have been better served by keeping C5 high and rather decreasing C3). What did other members encounter?

5. The capacitor C1=1nF (if I read correctly) in parallel with R4=100R, presumably for some h.f. stability, has a -3 dB (45 degree) effect above 1.5 MHz only, where there certainly is no loop gain left to cause any problems; the loop gain passes trough 1 at some 200+ KHz. Is C1=1nF correct?

I may add that all components have been replaced, so encountered stability effects are not as a result of aged components.

Any comments would be greatly appreciated.

Regards.
  Reply With Quote
Old 15th April 2006, 06:35 PM   #2
edl is offline edl  Hungary
diyAudio Member
 
edl's Avatar
 
Join Date: Oct 2004
Hi,

I give a link for the schema, hope it helps for the other members to answer your questions:
http://werple.net.au/~kiewavly/Leak/...s/Stereo20.gif

Best regards,
  Reply With Quote
Old 15th April 2006, 09:43 PM   #3
diyAudio Member
 
Join Date: May 2005
Location: Pretoria, South Africa
Thanks so much edl. That is exactly the diagram I have referred to.
  Reply With Quote
Old 17th April 2006, 01:35 AM   #4
anatech is offline anatech  Canada
diyAudio Moderator
 
anatech's Avatar
 
Join Date: Jun 2004
Location: Georgetown, On
Hi Johan,
I have one too that I haven't touched yet. I'll be watching.

That diagram is the one I have.

-Chris
  Reply With Quote
Old 17th April 2006, 11:23 AM   #5
TJ is offline TJ
diyAudio Member
 
Join Date: Sep 2001
Location: UK
hi all , the circuit diagram u got is the old one before 1965 !! it will run ur power transformer very hot and some will blow out !! Try search the internet for the circuit dirgram after 1965 the power should be 280- 0 -280 not 300v. hope this help .
  Reply With Quote
Old 18th April 2006, 12:18 AM   #6
diyAudio Member
 
Join Date: May 2005
Location: Pretoria, South Africa
Thanks TJ. Thus far I could not find a different circuit diagram, but the power transformer measures 280 - 0 - 280V and does not get too hot. There is no indication anywhere of the vintage.

Anatech,
I was forced to change component values slightly to get an acceptable amplifier - reluctantly so. As said above the feedback was overly high to my mind, and I decreased it to 15x by changing R18 (the feedback resistor) to 18K. Furthermore I found the phase compensation by C9 totally excessive. I lowered that to 68 pF, giving an almost perfect square wave response without a load (under which condition it was then stable), and a slight "undershoot" into an 8 ohm load. This looks better with loudspeaker load, which is higher than 8 ohm at h.f.

In this process I not only varied the C9 value, but also tried a serie resistor as is sometimes found. I found it best with no resistance in serie with C9.

Then I found C1 of no use, as said before. It very slightly increased the small damped oscillation at the onset of a square wave, and I omitted it.

I also changed R5 to 100K (as shown on the diagram; see above) and R3 to 1,5K to get the anode swing into a more linear region. (R3 could actually go to 1K for still better operation.) Also I later noticed that R12, R13 in my model were 470K, not 1M as per the diagram - I kept that value.

Lastly R2=22K gave a loop response of -3 dB at only 12 KHz. I lowered that to 4,7K, which also slightly improved the square wave (onset) response. I realise that that puts the input stage somewhat more at the mercy of the feeding impedance, but at least now it will be better with a low impedance feed. (My signal generator feeds from 600 ohm.)

These are a lot of changes by someone who likes to keep originals as was, but it could not be avoided. Incidentally, this was the 2nd Leak Stereo 20 that I had to alter in this manner, which lowers the chance that I might have an odd one here.

I must admit that I just cannot fathom the reasons for the original values. I am still hanging on in case someone else comes up with wisdom.

Regards.
  Reply With Quote
Old 18th April 2006, 02:05 AM   #7
anatech is offline anatech  Canada
diyAudio Moderator
 
anatech's Avatar
 
Join Date: Jun 2004
Location: Georgetown, On
Hi Johan,
Thanks so much! I filed your info for when I look at mine. I wonder if this has anything to do with the thought that the iron core degrades over time. You would in effect have a different part then.

-Chris
  Reply With Quote
Old 18th April 2006, 03:18 AM   #8
diyAudio Moderator Emeritus
 
ray_moth's Avatar
 
Join Date: Jan 2004
Location: Jakarta
Quote:
Then I found C1 of no use, as said before. It very slightly increased the small damped oscillation at the onset of a square wave, and I omitted it
Every Leak tube amp schematic that I can remember, from 12w to 50w, has that 0.001uF (C1) in there. I have never seen an explanation of what it's for and nobody else's design seems to use it.

The only thing I can think of is, maybe it's supposed to compensate for HF roll-off caused by the R-C network across the plate load of the first stage.
  Reply With Quote
Old 23rd April 2006, 07:51 PM   #9
diyAudio Member
 
Join Date: May 2005
Location: Pretoria, South Africa
Thanks everybody.

This would appear to conclude this for now - I have had no further inputs, also (not) from other sources. One or two other sites came up but a few years old - e-mail addresses not active any longer. I have since checked yet another Stereo 20 - same thing and findings. The original value choices must remain a mystery, until somewhere other wisdom comes up by chance.

Meet you on other threads.
  Reply With Quote
Old 23rd April 2006, 10:10 PM   #10
EC8010 is offline EC8010  United Kingdom
diyAudio Moderator Emeritus
 
EC8010's Avatar
 
Join Date: Jan 2003
Location: Near London. UK
I have to say that I'm as bemused as everyone else about that 1nF capacitor. It effectively forms a step network at RF that reduces feedback and long before that it affects the phase angle of the feedback. You can produce the same effect by adding a resistor in series with the capacitor bypassing the feedback resistor, and that's significant because the fairy fingers feedback box that I use for determining optimum feedback has a variable resistor in series with the bypass capacitor and on lots of experiments with different output transformers etc I've never yet seen adjusting R > 0 do anything but make the amplifier ring or oscillate.

That means I'm saying that Leak got it wrong. But a few things ought to be borne in mind. When the Leak valve amplifiers were designed an oscilloscope was genuinely laboratory equipment, as was the function generator (to produce the required square waves). Non-inductive dummy loads were also virtually unknown. Thus, an amplifier would have been tested using a dodgy source, driving a wirewound (inductive) dummy load, into an oscilloscope with perhaps 2MHz of bandwidth. It's no wonder that they arrived at seemingly inexplicable results. These days, a cheap and cheerful function generator is capable of producing a 10MHz fundamental so its 10kHz square waves are almost beyond reproach, 50W non-inductive metal film resistors are readily available, and it's difficult to buy an oscilloscope with a bandwidth of <20MHz.
__________________
The loudspeaker: The only commercial Hi-Fi item where a disproportionate part of the budget isn't spent on the box. And the one where it would make a difference...
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LEAK stereo 70 cutting out Minimuslover7 Solid State 10 24th August 2009 04:56 PM
Xindak attenuation for use with Leak Stereo 20, help please camperman Tubes / Valves 15 20th May 2008 07:12 PM
Leak Stereo 20 clone? possibly with 6V6? bikehorn Tubes / Valves 26 29th March 2007 01:52 AM
Leak stereo 70 fault harrygrey382 Solid State 16 25th February 2007 04:07 PM
Mods on leak stereo 20 bronto64 Tubes / Valves 22 26th April 2004 08:27 PM


New To Site? Need Help?

All times are GMT. The time now is 08:46 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2