Help needed in Bloomington IN - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th April 2006, 04:41 AM   #1
razz is offline razz  United States
diyAudio Member
 
Join Date: Apr 2006
Location: US
Unhappy Help needed in Bloomington IN

Hi I have a problem with an integrated p/p tube amp I recently purchased. I was led to believe from the seller and all literature/markings, etc that it was a 220v amp, yes a chinese one. When I hooked it up to 110v it worked but the tubes were dimly lit imo and the sound though nice sounded a little thin, so I bought a stup up converter and hooked it up. Well the tubes lit up allright for a few seconds then the fuse in the 800w converter blew (amp rated 250w) and a smell of overheated components eminated from the amp. Now only the right channel works, I tried switching the tubes and still only the right channel works. Seems this is a 110v unit afterall. I am over my head here and am seeking help from someone local who can troubleshoot this amp, I do have a schematic. Thank you all, farneyblakeley@lycos.com
  Reply With Quote
Old 7th May 2006, 04:18 AM   #2
razz is offline razz  United States
diyAudio Member
 
Join Date: Apr 2006
Location: US
----------bump---------
Another try
This is a dual power supply amp and I'm afraid I've fried one of the transformers, really miss that sound, the first all tube sound I'd ever heard, thanks all
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help needed ! Inter M R300 schematics needed ! alexclaire Solid State 30 9th September 2009 07:14 AM
LT1964-adj Help Needed or Part Needed lgreen Parts 2 29th June 2007 03:50 PM
Any DIYers around Iowa City, IA or Bloomington, IL TheDriver Pass Labs 0 14th July 2004 09:32 PM
Help needed here Original Burnedfingers Tubes / Valves 2 12th April 2003 04:20 AM


New To Site? Need Help?

All times are GMT. The time now is 06:41 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2