laney PA amp questions - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th September 2005, 10:22 AM   #1
diyAudio Member
 
Join Date: Jun 2005
Location: Aberystwyth / Llanelli (wales)
Send a message via MSN to DoomPixie
Default laney PA amp questions

Hey again,
Just got my hands on a nice Old laney Valve PA head, havent had a chance to play with it yet. it uses 4 EL34 output valves and is meant to kick out 100Watt, one of the EL34's were broken and the previous owner removed it (aparently the amp works fine without it but i will get a new quad of them anyway) the guy told me there is something wrong with the preamp section so i have to plug straight into the echo return socket but i plan on modding the preamp's so i can use it with bass and guitar anyway, it has 6 inputs each has an ECC83, then there is a seperate ECC83 and an ECC82 next to the power tubes , couldnt see any rectifier valves or PSU capacitors in it but it has a BIG power traffo and a BIG output traffo and a choke. anyone got any ideas why none of the proper inputs work? i was thinking that mabey one of the preamp tubes next to the power tubes are dead. :/
anyone know where i can find a schematic for an old laney valve PA head? i think the model number was LA100PA, not sure about the first two letters though.
anyone have any sugestions for modin g it for guitar use?
i was wanting the first chanel to be clean for bass and the second to be higher gain so it pushes the amp into distortion quicker. then the same for guitar and then the last two i will leave standard so i can use them with mic's or keyboard, will mean i have a nice all round amp.
thanks in advance,
Owen
  Reply With Quote
Old 7th September 2005, 04:05 PM   #2
diyAudio Member
 
Join Date: Jun 2005
Location: Aberystwyth / Llanelli (wales)
Send a message via MSN to DoomPixie
just had a good look over the amp and it seems that it has been serviced or repaired sometime in its past, power supply caps and some of the power supply resistors have been replaced and one of the tube sockets that the el34's go in has been replaced. one of the resistors on the power supply section is scorched, possibly a dropping resistor on the B+ for the preamp tubes ( or it looks like it could be) other than that it all looks nice and tidy and is very well built, all the transformers are made by partridge (SP?) all the valves look good, all the ECC83's are made b y brimar and the ECC82 and two of the EL34's are mazda (the EL34 that was dead and one that looks well used) the other two el34's are pinnacle (SP?) and appear to be newer than the mazda ones.
Owen
  Reply With Quote
Old 7th September 2005, 11:45 PM   #3
diyAudio Member
 
Join Date: Oct 2004
Location: Adelaide South Oz
The model is almost certainly LA100 which was known as the "Super PA".
Laney Schematics are very hard to find BUT I would go direct to Laney UK. They should be helpful.

In the mean time the output stage is probably much the same as this one:

http://www.drtube.com/schematics/laney/klipp100.gif

Given that NONE of the input channels are working I would suspect either a High Voltage failure tio the front end OR a faulty mixer stage which probably also drives the line out. Plenty of scope for a front end rebuild to suit what you want.

Cheers,
Ian
  Reply With Quote
Old 8th September 2005, 04:57 PM   #4
diyAudio Member
 
Join Date: Jun 2005
Location: Aberystwyth / Llanelli (wales)
Send a message via MSN to DoomPixie
im sideing towards a high voltage failure to the front end, i had a quick look the other day and there is a burned resistor in the psu section which i expect feeds the front end. i will have a poke around with a DMM when i have finished moveing house. it is indeed badged as a LA100PA SUPER. The power amp section looks the same as the one you posted but i havent actually looked at it in any detail as it isnt here with me. From what i remember the ECC83's on the inputs feed an ECC82 which feeds the ECC83 phase splitter which goes on to feed the power tubes. I am going to concentrate on getting it running properly as a valve PA head before i start modifying it, I want to ad a effects send and return on the back panel for linking up to my Zoom RFX1000 and probably i will add a footswitch socket to bypass that effects loop. other than that im not really sure what i'll do yet, it looks very well built, veryt sturdy chassis, majority of the caps look like mullard mustard caps, partridge transformers...
will keep you posted.
Owen
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LANEY B1 Amp - Blown outputs technotronic Class D 0 17th April 2009 07:42 PM
Laney HCM160B's transistor zvir Solid State 2 16th February 2009 10:23 PM
laney DP150 mods AdamB Solid State 12 9th March 2006 02:51 AM
Laney PA amp help! DoomPixie Tubes / Valves 15 28th November 2005 08:18 PM
laney VC50 tuneman Instruments and Amps 0 19th July 2004 10:49 AM


New To Site? Need Help?

All times are GMT. The time now is 12:32 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2