Vacuum tube modeling software - beta testers wanted - Page 2 - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 1st May 2005, 01:03 PM   #11
andrei is offline andrei  Canada
diyAudio Member
 
Join Date: Dec 2002
Location: Canada
Err, e = 2.7182818...
  Reply With Quote
Old 2nd May 2005, 12:25 AM   #12
wa2ise is offline wa2ise  United States
diyAudio Member
 
wa2ise's Avatar
 
Join Date: Apr 2005
Location: NJ
Quote:
Err, e = 2.7182818...
DUH! of course, you're right. Easily corrected in the models I edited......
  Reply With Quote
Old 11th May 2005, 06:20 AM   #13
andrei is offline andrei  Canada
diyAudio Member
 
Join Date: Dec 2002
Location: Canada
The first public code release is out on SourceForge - download it here.
  Reply With Quote
Old 11th May 2005, 08:14 AM   #14
andrei is offline andrei  Canada
diyAudio Member
 
Join Date: Dec 2002
Location: Canada
BTW, I just checked that the Curve Captor GUI basically runs under Windows XP (there are a few glitches that I will have to take care of), so Windows binary release might be feasible. I have also tested it on Sun workstations running Solaris.
  Reply With Quote
Old 11th May 2005, 10:06 AM   #15
LuisMCP is offline LuisMCP  Spain
diyAudio Member
 
LuisMCP's Avatar
 
Join Date: Jun 2001
Location: Madrid, Spain
Quote:
Originally posted by andrei
BTW, I just checked that the Curve Captor GUI basically runs under Windows XP (there are a few glitches that I will have to take care of), so Windows binary release might be feasible. I have also tested it on Sun workstations running Solaris.

Hola a todos. Andrei,

Your Curve Captor seems very interesting for me.

I have run your models in pspice (orcad / microsim) and some parameters are unknown (uramp).

I am another user of windoze...

Hasta luego.
  Reply With Quote
Old 14th May 2005, 07:44 AM   #16
andrei is offline andrei  Canada
diyAudio Member
 
Join Date: Dec 2002
Location: Canada
By popular demand, Windows version is now available . You will need to install Tcl/Tk first. Download it from ActiveState website. It is nicely packaged and has all the documentation included. Then download the Curve Captor WinXP binary distribution here. I have included m4 binary, so you don't need to download anything else. No fancy installer yet - just unzip somewhere and start curvecaptor binary.

I am attaching 6SN7 data files to play around with. Try opening 6SN7.dat first and generate a model. If you want to see how the traced curves look, open 6SN7.gif and load markers from 6SN7.crv

This is the first Windows port I've done - there might be bugs. Email me if there is trouble.
Attached Files
File Type: zip 6sn7.zip (38.8 KB, 284 views)
  Reply With Quote
Old 14th May 2005, 07:49 AM   #17
andrei is offline andrei  Canada
diyAudio Member
 
Join Date: Dec 2002
Location: Canada
Oh yes, PSpice syntax is incompatible with the standard 3F4. Since the models are macro based, it is simple to change the syntax. I am not using PSpice myself, so this has been low priority for me. I'll make a PSpice version once I get a hold of PSpice reference manual. In the future release, I'll probably add a Spice dialect selector dialog...
  Reply With Quote
Old 14th May 2005, 01:23 PM   #18
RIP
 
pedroskova's Avatar
 
Join Date: Dec 2002
Location: C'ville VA, USA
it's "killing children"


  Reply With Quote
Old 14th May 2005, 06:40 PM   #19
andrei is offline andrei  Canada
diyAudio Member
 
Join Date: Dec 2002
Location: Canada
Email me a detailed bug report. I am not telepathic; if you don't explain what's wrong, I cannot fix it.
  Reply With Quote
Old 14th May 2005, 09:50 PM   #20
LuisMCP is offline LuisMCP  Spain
diyAudio Member
 
LuisMCP's Avatar
 
Join Date: Jun 2001
Location: Madrid, Spain
Default errors in tcl

Hi Andrei,

When I push button "Build Model" an error message is shown:

child killed: illegal instruction
child killed: illegal instruction
while executing
"exec $backend -$type -m << [$t get 0.0 end]"
(procedure "model" line 9)
invoked from within
"model $wd.text"
invoked from within
".n.f1.buttons.model invoke"
("uplevel" body line 1)
invoked from within
"uplevel #0[list $w invoke]"
(procedure "tk::ButtonUp" line 24)
invoked from within
"tk::ButtonUp .n.f1.buttons.model"
(command bound to event)


Regards.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wanted: Coral Beta 8 or Beta 10 full range speaker francofil Swap Meet 2 28th April 2010 08:34 AM
Vacuum Tube Computer Simulation Modeling oldheathkitphil Tubes / Valves 11 19th July 2007 02:12 PM
HELP with Box Modeling Software 69stingray Multi-Way 5 1st January 2006 04:40 PM
Need help with Modeling Software Wright Multi-Way 26 17th November 2003 01:23 PM


New To Site? Need Help?

All times are GMT. The time now is 03:33 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2