no bass makes pedro a whiny boy - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th September 2004, 05:54 PM   #1
RIP
 
pedroskova's Avatar
 
Join Date: Dec 2002
Location: C'ville VA, USA
Default no bass makes pedro a whiny boy

Hi all,

Yesterday, I swapped out the 6J5 cathode follower that is my line stage for a push-pull stage based on a Schmidt phase splitter that drives cheap Edcor line transformers(see below and here) .

Well, it worked - sort of - but there is literally no bass. I bought the Edcors to try something like this as a proof of concept. Yes, they're cheap, but they're only driving my amp. Other than the transformers, is there anything that I might have done to cause this?

Could it be the highish Rp of the 6SN7? Would a 6BL7 be a better choice?

thx,

pete



Click the image to open in full size.
  Reply With Quote
Old 28th September 2004, 02:52 AM   #2
diyAudio Member
 
Geek's Avatar
 
Join Date: Sep 2004
No wonder.

1) lose the current source
2) feed it with a proper phase splitter
3) use a decent transformer. Crap tranny = crap sound
  Reply With Quote
Old 28th September 2004, 03:11 AM   #3
diyAudio Senior Member
 
fdegrove's Avatar
 
Join Date: Aug 2002
Location: Belgium
Hi,

Cheers,
Attached Images
File Type: gif 6sn7_pp_ls_mod.gif (5.6 KB, 105 views)
__________________
Frank
  Reply With Quote
Old 28th September 2004, 05:02 PM   #4
RIP
 
pedroskova's Avatar
 
Join Date: Dec 2002
Location: C'ville VA, USA
Quote:
Originally posted by Geek
No wonder.
Yes - wonder - stated specs: 20-30k +/-.5dB ...sounded like a 1st order x-over had been inserted@~200Hz

Quote:
1) lose the current source
Current sink needed (see thread below).

Quote:
2) feed it with a proper phase splitter
Proper phase splitter (see same thread below).

Quote:
3) use a decent transformer. Crap tranny = crap sound
thanks for the input

compact amp thread



ps - got some semblance of bass by upping current sink to 20mA.


pg
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Does anyone know what amp this is and who makes it? MikeHunt79 Car Audio 8 16th January 2008 11:06 PM
Anybody know who makes... Steve Eddy Parts 10 12th July 2005 04:58 PM
It makes me wonder ... Gluca Tubes / Valves 17 24th May 2005 02:59 PM
Deep bass makes me sick? Paradise_Ice Car Audio 15 23rd June 2004 04:12 PM
For all Bass Junkies out there (Behringer Bass processor usage report) VEC7OR Digital Line Level 5 27th October 2003 10:18 AM


New To Site? Need Help?

All times are GMT. The time now is 07:38 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2