Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Need help with MBLE full stereo 4-4 plus
Need help with MBLE full stereo 4-4 plus
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th February 2018, 02:18 PM   #1
Sceptic Hall is offline Sceptic Hall  Netherlands
diyAudio Member
 
Join Date: Feb 2018
Default Need help with MBLE full stereo 4-4 plus

Hello, seeking info I stranded here on this forum. Apologize for my senses because my language is Dutch.
I hope someone can help me with my problem, I got a MBLE Full Stereo Amplifier 4 - 4 plus and I cleaned it. Removed dust, cleaned contacts end repaired the selector indicator. It works but not as it supposed to do. When it plays at a low volume the left side is much louder. When the volume goes up the balance need to correct to the center. Who knows whats wrong with it.

Peter

Last edited by Sceptic Hall; 15th February 2018 at 06:34 AM.
  Reply With Quote
Old 14th February 2018, 02:23 PM   #2
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Need help with MBLE full stereo 4-4 plus
Welcome to diyAudio Peter

If the left/right balance shifts with volume setting (and is basically normal at higher levels) then the problem may be nothing more than the two gangs of the volume control being poorly matched (a common issue). The only fix for that is replacement.

If the balance is consistently one sided throughout the whole volume range then more detailed investigation is needed as that would suggest a gain imbalance somewhere.
  Reply With Quote
Old 14th February 2018, 02:53 PM   #3
Sceptic Hall is offline Sceptic Hall  Netherlands
diyAudio Member
 
Join Date: Feb 2018
Thank You for the reply. Ok it's the first option. But what do You mean by replacement. What do I replace? Potentiometer?
  Reply With Quote
Old 14th February 2018, 03:02 PM   #4
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Need help with MBLE full stereo 4-4 plus
Yes, the dual gang volume control (potentiometer) would be the most likely suspect and needs to be replaced. For audio we normally use a 'log' or logarithmic control rather than a linear type.

You might find some useful information here:
Potentiometers (Beginners' Guide to Pots)
  Reply With Quote
Old 14th February 2018, 03:38 PM   #5
Sceptic Hall is offline Sceptic Hall  Netherlands
diyAudio Member
 
Join Date: Feb 2018
ok, thank You.
  Reply With Quote
Old 14th February 2018, 04:41 PM   #6
Alan4411 is offline Alan4411  Wales
diyAudio Member
 
Join Date: Oct 2011
Location: West Wales
If you have not already tried, swap the valves over from side to side.
Try the ECC83s (shortest valves) first. Then the two EL84s. See if that changes anything. (The EZ81 will be fine.)

Have a look to see if any wires have come loose, especially the feedback wire from the output transformers. And round the volume / balance controls. You could try squirting a little switch cleaner into the pots as well.

I assume you have tested all the inputs and the fault is the same on all of them?
  Reply With Quote
Old 14th February 2018, 04:56 PM   #7
Sceptic Hall is offline Sceptic Hall  Netherlands
diyAudio Member
 
Join Date: Feb 2018
Hello Alan4411, I will try your options and let you know.
  Reply With Quote
Old 14th February 2018, 08:18 PM   #8
audiowize is offline audiowize  United States
diyAudio Member
 
Join Date: Aug 2005
Location: Seattle
Send a message via AIM to audiowize
Can you post up the schematic here (I don't have an account to download it). If the above suggestions don't work out, you will likely need to take some basic DC voltage measurements in each channel.
  Reply With Quote
Old 15th February 2018, 05:13 AM   #9
Sceptic Hall is offline Sceptic Hall  Netherlands
diyAudio Member
 
Join Date: Feb 2018
Hello Audiowise here are schematics.
  Reply With Quote
Old 20th February 2018, 08:54 AM   #10
Sceptic Hall is offline Sceptic Hall  Netherlands
diyAudio Member
 
Join Date: Feb 2018
Ok problem solved. Replace volume and balance potmeter. Thanks everyone.
  Reply With Quote

Reply


Need help with MBLE full stereo 4-4 plusHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mauro Penasa MyRef Rev C 3886 Stereo Amplifier with TDA7294 Stereo Woofer Amp VictoriaGuy Swap Meet 8 6th February 2017 10:16 PM
Full digital stereo amplifier QLS QA100, any comments? lxiaob Solid State 10 15th November 2014 06:54 AM
Cigar box stereo full range Ideas and more Rick B Full Range 14 26th September 2013 08:01 PM
TAS5706 simple full digital stereo amplifier KOON3876 Class D 53 23rd September 2008 01:04 PM
No Full Stereo Seperation ..???? xitronics Everything Else 2 7th July 2005 09:25 AM


New To Site? Need Help?

All times are GMT. The time now is 11:08 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki