Fisher 800C FM Stereo problem - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th March 2004, 05:45 PM   #1
diyAudio Member
 
Join Date: Feb 2004
Location: Victoria
Default Fisher 800C FM Stereo problem

I am having a problem with my Fisher 800C in that when in FM stereo filter mode,
the left channel is really attenuated (Quiet).(all stations)
L and R are loud and clear in FM mono mode so I don't think it's anything in the audio section.
I've heard about upgrades to these tuners something to do with old de-emphasis circuitry that is not compatible with modern
broadcast??
Please help.
  Reply With Quote
Old 12th March 2004, 05:01 AM   #2
diyAudio Member
 
Join Date: Feb 2004
Location: Victoria
Default Found the problem

Wow I can't believe no one responded to this tempting puzzle.
For the benifit of anyone who runs across a similar problem
it turned out to be a (partially)bad 12Ax7.
Swapped the tube and problem was gone.
From now on I will suspect 40 year old tubes first.
  Reply With Quote
Old 12th March 2004, 05:24 AM   #3
SHiFTY is offline SHiFTY  New Zealand
diyAudio Member
 
SHiFTY's Avatar
 
Join Date: Jul 2002
Location: New Zealand
Glad you fixed it

I think you had a jargon alert in your first post!
  Reply With Quote
Old 13th March 2004, 04:45 AM   #4
diyAudio Member
 
Join Date: Sep 2002
Location: Memphis, TN
Hi,

I've a similar problem in my 500B. Which 12ax7 did you swap?

Regards,
ck
  Reply With Quote
Old 2nd April 2004, 04:43 AM   #5
diyAudio Member
 
Join Date: Feb 2004
Location: Victoria
Default Which Tube

In the MPX section:
It was V102 th one connected to the MPX seperation Pot.
Good Luck.
  Reply With Quote
Old 2nd April 2004, 10:46 AM   #6
diyAudio Member
 
Join Date: Sep 2002
Location: Memphis, TN
Thanks,

Will pull my 500 out and check it out..

Regards,
ck
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fisher 800c static,crackle skiman762 Tubes / Valves 2 9th April 2009 03:59 PM
Fisher 800c neg bias problem Glowin Plates Tubes / Valves 10 26th September 2008 08:39 AM
fisher 800c intermitant hum slhoward Tubes / Valves 1 28th May 2007 04:16 PM
fisher 800c modifications slhoward Tubes / Valves 1 15th May 2007 11:25 PM
Distortion in Fisher 800C Glowin Plates Tubes / Valves 1 2nd November 2005 06:57 PM


New To Site? Need Help?

All times are GMT. The time now is 05:56 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2