diyAudio (
-   Tubes / Valves (
-   -   Fisher 800C FM Stereo problem (

Glowin Plates 6th March 2004 05:45 PM

Fisher 800C FM Stereo problem
I am having a problem with my Fisher 800C in that when in FM stereo filter mode,
the left channel is really attenuated (Quiet).(all stations)
L and R are loud and clear in FM mono mode so I don't think it's anything in the audio section.
I've heard about upgrades to these tuners something to do with old de-emphasis circuitry that is not compatible with modern
Please help.:whazzat:

Glowin Plates 12th March 2004 05:01 AM

Found the problem
Wow I can't believe no one responded to this tempting puzzle.
For the benifit of anyone who runs across a similar problem
it turned out to be a (partially)bad 12Ax7.
Swapped the tube and problem was gone.
From now on I will suspect 40 year old tubes first.

SHiFTY 12th March 2004 05:24 AM

Glad you fixed it :)

I think you had a jargon alert in your first post!

Ciscokid 13th March 2004 04:45 AM


I've a similar problem in my 500B. Which 12ax7 did you swap?


Glowin Plates 2nd April 2004 04:43 AM

Which Tube
In the MPX section:
It was V102 th one connected to the MPX seperation Pot.
Good Luck.:D

Ciscokid 2nd April 2004 10:46 AM


Will pull my 500 out and check it out..


All times are GMT. The time now is 07:19 PM.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2