Leak tl12+ ECC81 - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th November 2013, 09:26 PM   #1
mickg is offline mickg  England
diyAudio Member
 
Join Date: Mar 2013
Default Leak tl12+ ECC81

I fired up my Leak TL12+'s the other day and I noticed that on one of the amps the ECC81 heater glowed very brightly for a few seconds until it had warmed up. I have not noticed this before and wondered whether it was indicative of impending failure of the valve. The sound quality does not seem to have been affected.
Has anyone experienced this before ?

thanks.
  Reply With Quote
Old 16th November 2013, 09:34 PM   #2
diyAudio Member
 
Join Date: Nov 2011
Location: Chippenham
Send a message via Skype™ to peterfarrow
this is fairly normal for Leak amplifiers...
My stereo 20s, TL12+ and stereo60 all did this...
  Reply With Quote
Old 16th November 2013, 09:36 PM   #3
diyAudio Member
 
vinylkid58's Avatar
 
Join Date: May 2005
Location: Victoria, B.C.
Heater flash is a well known characteristic of Mullard valves. That's probably all it is.

jeff
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Leak TL12+ smoothing capacitors. mickg Tubes / Valves 5 3rd June 2013 07:16 PM
speakers for leak tl12+ mickg Tubes / Valves 0 13th March 2013 09:58 PM
leak tl12+ mickg Tubes / Valves 4 7th March 2013 09:48 PM
Leak TL12 + Tannoy 15" jkeny Everything Else 1 4th March 2006 04:08 PM
Leak TL12 replica using 807s? SHiFTY Tubes / Valves 3 19th April 2003 04:55 PM


New To Site? Need Help?

All times are GMT. The time now is 02:14 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2