PP KT88, Need help! - Page 5 - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 30th November 2012, 11:38 PM   #41
12E1 is offline 12E1  United Kingdom
diyAudio Member
 
12E1's Avatar
 
Join Date: May 2012
Location: Near Huntingdon, Cambridgeshire, UK
Quote:
Originally Posted by EEApprentice View Post
I haven't been able to check anything when the feedback is connected for that channel. It is so loud I have to turn it off and I don't have a resistor box handy to load the output.
I wouldn't worry about a resistor box as such - many resistor boxes are not designed to handle significant power. I would find a pair of 8 ohm or similar wire-wound resistors rated to 25 or 50 watts. They can be ceramic, but I like using the aluminium clad ones since they can easily be bolted onto a more substantial piece of metal. Here's some.
  Reply With Quote
Old 30th November 2012, 11:55 PM   #42
diyAudio Member
 
scott17's Avatar
 
Join Date: Aug 2009
Location: JFK
It does seem very possible that your left channel output transformer primary is wired in reverse compared to the right channel. That would give you positive feedback.

Right channel could be blocking distortion. http://www.aikenamps.com/BlockingDistortion.html

Last edited by scott17; 30th November 2012 at 11:57 PM.
  Reply With Quote
Old 1st December 2012, 06:49 PM   #43
diyAudio Member
 
Join Date: Sep 2012
Scott17 I will forever love you.

THE AMP IS FIXED! Not only that, it COMPLETELY exceeded my expectations. I cannot believe I've spent weeks and weeks trying to fix something that was just the primary of the left OPT wired in reverse. It was positive feedback all along!

I also added 1.7k grid stoppers to all my KT88s and replaced the capacitors for the fluttering channel.

THANK YOU EVERYONE! I was so disappointed when this thing didn't work but thanks to everyone throwing their ideas, it is finally fixed... And it sounds AMAZING.

Thank you again!
  Reply With Quote
Old 1st December 2012, 06:54 PM   #44
DF96 is offline DF96  England
diyAudio Member
 
Join Date: May 2007
Getting the feedback phase wrong is a very common mistake in a new DIY amplifier. Occasionally the OPT secondary will be mislabelled. That is why we asked you to check it.
  Reply With Quote
Old 1st December 2012, 09:17 PM   #45
diyAudio Member
 
scott17's Avatar
 
Join Date: Aug 2009
Location: JFK
I glad you've got it working and that you are happy. Fantastic.

I guess it's burned into you now to check that next time around.

Last edited by scott17; 1st December 2012 at 09:22 PM.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kt88 PP rectifier. ruben alstad Tubes / Valves 7 5th September 2012 09:07 AM
Which KT88 PP and which Transformers? Dave S Tubes / Valves 66 8th January 2012 04:37 PM
Kt88 Pp barossi Tubes / Valves 2 24th December 2008 05:55 PM
KT88 PP suggestion jarthel Tubes / Valves 13 27th June 2007 02:10 AM
My new pp KT88 design baggystevo82 Tubes / Valves 41 16th May 2005 01:02 PM


New To Site? Need Help?

All times are GMT. The time now is 07:51 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2