help, Built from scratch Kalamazoo 2 noise - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd September 2012, 08:35 PM   #1
nower is offline nower  United States
diyAudio Member
 
Join Date: Oct 2010
Location: earth (the west side)
Default help, Built from scratch Kalamazoo 2 noise

My first tube amp build from complete scratch is a Kalamazoo 2. I picked it only because it seemed to be simple enough while still having tremolo.
the problem: a foggy ground hum (as I expected)
a screech
I used a star ground method and hit every point so I think I'm stuck with the hum. The screech though, it appears at 3/10 on the volume pot and increase in volume as I turn it up. The tone pot does eliminate it tho, if I turn the Tone down it subsides with only implied buzzing (kinda hard to explain)
I have replaced the tubes, checked all soldering/wiring, temporarily lifting the ground, and even temporarily bypassing the rectifier tube with diodes (last resort). nothing effects the screech except that tone knob.
If you could give me a clue, I'd appreciate it. If I can give you more info to help I'll post it. Thank you for your time.
Here is a link to the schem and info on it.

Kalamazoo Amp Field Guide (frames)
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Calling John *Zaph*... 5.25" midwoofer designed/built from scratch OlogyAudio Multi-Way 19 24th August 2011 07:44 PM
Starting from scratch ? SimZeSun Multi-Way 4 16th August 2011 01:41 PM
Has anyone here built a noise filter? spooney Car Audio 2 27th December 2010 03:40 AM
Greetings from Kalamazoo,MI penniesfromheav Introductions 3 9th October 2007 09:28 PM
First build from scratch. castlesteve Tubes / Valves 0 29th January 2004 03:33 PM


New To Site? Need Help?

All times are GMT. The time now is 06:54 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2