Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 31st August 2012, 03:34 AM   #1
diyAudio Member
 
Join Date: Oct 2007
Default Driving a Behringer INuke Nu1000

I wanted a preamp for this stereo PA. I have a Fenderish 3 stage style ECC189 based preamp driving my 100W Linsley Hood mosfet power amp, it has plenty of signal, enough to crank the PA. Tried this preamp with this Behringer stereo PA and it seems it's not enough to deliver its maximum output power (plugged into a 4x10 cab wired 2 by 2, so it would be 300W per speaker pair), and led peak indicator goes up to red (don't know if it's a signal or a peak detector). Any info about this power amp sensitivity?

I'm thinking on a 6SN7, maybe 6SL7, or just 12AX7 based 3 stage preamp a-la-Fendre, I think it will be enough signal to drive the amp, my ECC89 preamps has about 90V DC supply, and it's quite clean (even with vol at max doesn't distort).

Any ideas?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Behringer iNuke NU3000 w/o any fan...? Soldermizer Class D 127 3rd April 2014 11:49 PM
Behringer iNuke NU3000 Measurements bolserst Class D 62 20th March 2014 02:52 AM
OB with vintage Seas and Behringer Inuke DSP zmyrna Full Range 2 23rd April 2012 09:36 AM
nu1000 and mono subwoofer tvojmuuc Subwoofers 2 9th December 2011 10:23 AM
Behringer DEQ ok driving multiple loads brucemck2 Subwoofers 0 18th January 2006 09:49 PM


New To Site? Need Help?

All times are GMT. The time now is 08:12 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2