Yaqin MS-22b Phono Amp - Page 2 - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th August 2012, 07:04 PM   #11
diyAudio Member
 
Join Date: Feb 2009
So basically, you removed the ground from the 2 original (black) cables on the input and connected the ground directly from the input RCA to the chassis ?
  Reply With Quote
Old 9th August 2012, 07:28 PM   #12
DF96 is offline DF96  England
diyAudio Member
 
Join Date: May 2007
No, the opposite of that! The incoming phono cable should not be connected to any chassis anywhere. It should connect to the preamp circuit, and use whatever ground arrangements that has. The RCA sockets should be isolated from chassis so only grounded via the internal cable and the preamp circuitry.
  Reply With Quote
Old 9th August 2012, 07:44 PM   #13
diyAudio Member
 
Join Date: Feb 2009
humm ok, any particular place where I could solder then the input ground on the circuit?

A photo of your circuit maybe ?
  Reply With Quote
Old 9th August 2012, 07:47 PM   #14
DF96 is offline DF96  England
diyAudio Member
 
Join Date: May 2007
What do you mean by input ground? Are you asking about how to connect the incoming phono signal to the circuit ground? If so, I have already answered that - it goes to the circuit ground, not the chassis.

If you are asking about the circuit ground then that depends on your circuit, not my circuit!
  Reply With Quote
Old 9th August 2012, 08:21 PM   #15
diyAudio Member
 
Join Date: Feb 2009
As mentionned above, I just tried to disconnect the 2 input sockets from the pcb and tried the pre amp like this.

Unfortunately, the humm is still here and even slightly louder...

Here is the schematic of the pre amp:
Click the image to open in full size.
  Reply With Quote
Old 9th August 2012, 08:54 PM   #17
DF96 is offline DF96  England
diyAudio Member
 
Join Date: May 2007
The signal return (or screen) of the phono cable should connect to the bottom end of R11/R14 as that is the point which sets the input signal ground reference.

If wired incorrectly it is possible that C15 injects ripple at this point.
  Reply With Quote
Old 9th August 2012, 09:09 PM   #18
diyAudio Member
 
Join Date: Feb 2009
Guys,

Got it !

If you look at one of the pix I sent, there is a ground yellow cable that is going from the pcb ground to the chassis.

I disconnected it from the chassi and that's it: no more hum !!!! ;-) (so happy now)

I don't know why the hell YAQIN put this cable here !

However, I still have this "poc" in my speakers when I m changing channels from aux to phono...

Steph

Last edited by SDIESEL77; 9th August 2012 at 09:14 PM.
  Reply With Quote
Old 10th August 2012, 11:04 AM   #19
diyAudio Member
 
Join Date: Feb 2011
Default Yaqin MS-22b Phono Amp

Hi

What I actually ment was that if you look at the input phono connections your'll see that the ground/negatives are soldered together. I split these apart from each other and the hum was gone.

I tried disconnecting the wire to the chasis but in my case it did not make any difference.

Still trying to trace the source of the hum from my DIY SUT - you wouldn't think it would be so difficult. However trial and error I suppose.

Regards
  Reply With Quote
Old 11th August 2012, 07:34 AM   #20
diyAudio Member
 
Join Date: Feb 2009
Quote:
Originally Posted by pegwill View Post
Hi

What I actually ment was that if you look at the input phono connections your'll see that the ground/negatives are soldered together. I split these apart from each other and the hum was gone.

Regards
I'll try today and will let you know the result on mine
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yaqin MS 12B phono amp- reviews Zero One Analogue Source 105 7th July 2014 09:45 AM
YAQIN MS-22B. Any thoughts, please? vincula Tubes / Valves 12 10th April 2013 06:07 PM
FS: Yaqin MS-12B Tube Phono Preamp tronan Swap Meet 0 21st July 2012 08:47 PM
Help - YAQIN MS-20L schematic pigeon_snake Tubes / Valves 4 11th January 2012 12:49 AM
Yaqin MS-300B SET amp Rodango Tubes / Valves 18 26th November 2010 08:09 AM


New To Site? Need Help?

All times are GMT. The time now is 06:51 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2