diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Tubes / Valves (http://www.diyaudio.com/forums/tubes-valves/)
-   -   My amp is motorboating, improve it with b+ regulator ? (http://www.diyaudio.com/forums/tubes-valves/211329-my-amp-motorboating-improve-b-regulator.html)

yurgs 22nd April 2012 07:21 PM

My amp is motorboating, improve it with b+ regulator ?
 
1 Attachment(s)
hey there, i have a problem with my amp (integrated KT88PP, with 5814A as input and drivers).
i changed the circuit with diffent valves, added ccs to the input stage and reduced the resistors R7 & R8 in the powersupply to maintain the designed voltages.
If i start testing with signals <40Hz it starts oscillating at about1 Hz. (visible on the bias balance leds) and there is some "squeeging" at f>2kHz.
it must be connected to the smaller resistance in the supply (R7 is reduced from 1k8 t0 560r, R8 is reduced from 6k8 to 3k9).
My question now is, can i improve the supply by changing to a regulator design?
i think the 21st Century Maida Regulator thread on DIY Audio.
looks promising, or do you know better or simpler designs
or maybe use 2 of these regs to supply the driver and input tubes on each channel seperately. i would need about 144mA each side for bias.
possibly its enough to reduce the voltage on input B+ from 320 to 280V, since that would be enough for the ccs to operate? any help is appreciated :)
Thanks

jan.didden 22nd April 2012 07:57 PM

Maybe post the amp circuit instead. Motortboating comes from a feedback (positive) at those frequencies. probably better to verify that first, getting to the root cause.

jan didden

yurgs 22nd April 2012 08:14 PM

2 Attachment(s)
Here are the circuits, the reason for me thinking its the suppy is that i noticed oscillations after i changed the resistors..
The amp is not really "finished" i built it and i have to adjust gain shelving and nfb.
(and its oscillating with and without nfb at described frequencies, no matter what values i use for the shelf.):(

jan.didden 22nd April 2012 08:20 PM

Motorboating is often related to lf ground coupling. Did you check with R1 shorted? Seems pretty high at 15 ohms, especially if the supply is grounded directly.

jan

Zen Mod 22nd April 2012 08:25 PM

make better CCS - made of two BJT's

I'm lazy for remembering , but maybe proper name is Widlar or something

it seems pictured here : Google Image Result for http://upload.wikimedia.org/wikipedia/commons/thumb/8/84/Widlar_Patent.PNG/350px-Widlar_Patent.PNG

in that case make R31 group of two series resistors (say 100K+120K) and put filtering cap from their junction to pos rail

Chris Hornbeck 22nd April 2012 11:19 PM

Another possibility is that the subsonics are another artifact, in addition to the squeeging, of the parasitic oscillation. It's common for grid coupling time constants to charge up with grid forward conductance and then discharge at about that rate. A relaxation oscillator of sorts.

I'd be tempted to fix the parasitics first, then see if the subsonics are automagically cured too.

All good fortune,
Chris

tomchr 24th April 2012 07:29 PM

1 Attachment(s)
Quote:

Originally Posted by yurgs (Post 2996568)
If i start testing with signals <40Hz it starts oscillating at about1 Hz. (visible on the bias balance leds) and there is some "squeeging" at f>2kHz.

Have you changed the loop gain of the circuit? Which valves were replaced, which valves were used originally and what were they replaced with?

Quote:

Originally Posted by yurgs (Post 2996568)
My question now is, can i improve the supply by changing to a regulator design?
i think the 21st Century Maida Regulator thread on DIY Audio.
looks promising, or do you know better or simpler designs

A zener stack with an emitter follower output is the simplest I can think of. It's not the best performer, but it's the simplest. I actually went through quite a few regulator designs before designing the 21st Century Maida. It's a rock solid regulator.

However, before changing to a regulator, let's fix your amp. As Jan points out, the motor boating and squeeging are caused by instability in the circuit.

Quote:

Originally Posted by yurgs (Post 2996568)
i would need about 144mA each side for bias.
possibly its enough to reduce the voltage on input B+ from 320 to 280V

Yeah, the 21st Century Maida Reg can do that just fine. No issues there.

Quote:

Originally Posted by janneman (Post 2996600)
Maybe post the amp circuit instead. Motortboating comes from a feedback (positive) at those frequencies. probably better to verify that first, getting to the root cause.

Couldn't have said it better.

Quote:

Originally Posted by Zen Mod (Post 2996638)
make better CCS - made of two BJT's
I'm lazy for remembering , but maybe proper name is Widlar or something

The CCS'es could be improved, but I don't think that's the source of the problems. Especially, if they provide a reasonably constant current they way they're currently configured. This can be confirmed by measuring the voltages across the emitter resistors.

However, if the CCS'es are causing trouble, I suggest replacing them with attached. It's a CCS that I've been playing with lately. It provides a nice, temperature compensated current source. It's fairly low gain compared to the one Zen Mod is referring to (I believe that one what Morgan Jones calls the "Ring of Two"). This is completely intentional. I've had issues with the Ring of Two oscillating on transients. The Ring of Two is also not temperature compensated (as the transistors heat up, the bias current will vary significantly).
If you choose to use my CCS, set up the current in R2, R3 around a few hundred uA (limit the dissipation in R3). Calculate R2 such that you get roughly 10 V across it. Also, keep the two PNP's close together - preferably thermally connected to each other. The output impedance of this current source is extremely high - exactly what you want for a CCS - due to the cascode (the PMOS). You can turn the circuit upside down and use NPN/NMOS devices for a current sink if you like.

But to get back to your amp. Are you able to run it with the global negative feedback disconnected? If that's possible, then you definitely have stability issues.

~Tom

MelB 24th April 2012 10:09 PM

Reduce C23 to 220uF....then 100uF.

yurgs 28th April 2012 08:59 AM

1 Attachment(s)
Thanks for the replies,
I’ve been away for work this week, but back on track now..
@jannemann : no difference with R1 shorted.
@ Chris Hornbeck : „I'd be tempted to fix the parasitics first, then see if the subsonics are automatically cured too.”
I was hoping it works the other way around too:), since I am limited with my test gear (pete millets soundcard interface on my pc, and a digital oscilloscope with less than average bandwidth…)
@tomchr : I replaced V1,V2,V3,V4, all were originally 6CG7 (see original circuit attached) and I wanted to use the 5814A I have.
If I calculated the gain right, it was about 6.2 for V1 in the original circuit, with 5814 paralled @5mA each half I get gain=13.6 , so maybe that’s already causing my problem.


without feedback it gets worse....


Morgan jones writes that interstage decoupling caps can cause motor boating on Williamsons, so I detached C25 for testing with 5kHz and 20Hz,and it changed :
the sqeeging gets worse, the motorboat gets smaller( valves start drawing grid current at about 5V Vo instead of 2,8V).
I have not changed the value of C23 yet. I should have some time this weekend.

greetings from a finally sunny germany

artosalo 28th April 2012 10:26 AM

In your first schematic there is mentioned that the global NFB should be 14 dB.
Now you have changed tubes and added CCS. It is obvious that the amount of negative feedback is not 14 dB anymore.

Measure the gain difference when R10 is short circuited and normal.
What is the result ?
If you short circuit R10, is there still mororboating ?


All times are GMT. The time now is 11:26 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2