Welborn Labs - Abysmal Service - Page 2 - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th December 2012, 11:48 AM   #11
freax is offline freax  Australia
diyAudio Member
 
freax's Avatar
 
Join Date: Sep 2007
Location: NSW
I ordered some capacitors and some silver solder from them in 2004, had to wait 4 weeks but I got it.
__________________
"It seems that perfection is reached not when there is nothing left to add, but when there is nothing left to take away" - Antoine de Saint Exupéry
  Reply With Quote
Old 15th December 2012, 02:14 AM   #12
diyAudio Member
 
Join Date: Sep 2011
Location: Sheffield
It is strange how Welborne Labs have no contact number only email. I suppose they can just put ripped off customers on their blocked email list.
  Reply With Quote
Old 21st February 2014, 05:19 PM   #13
diyAudio Member
 
Join Date: Feb 2010
Location: Eastern Ontario CA.
Default Welborn Labs - Abysmal Service

Okay so you didn't get your stuff! So what are you going to do about it? Through the replies I got from members here, I know some of you would rather take a "Wait and see" approach given Welborne is a small supply company.
I took evasive action two weeks after the replies stopped coming. I feel my situation warranted immediate action. I was told, by Misses Welborne, that someone had ordered their CATO2 and did not pick it up! With that I thought it would be at my door as soon as the mail could move it! NOT!!!
So, I contacted a collection agency and gave the agent all of my pertinent info. I then sat back and let them do the work as I have little to no resources to apply any king of pressure. Well after two months of letting the agent twist their arm, my order arrived. 99% complete, but at this stage I am satisfied. For good reason, there was no explanation or apology.
I have gotten the wrong case for my project, but then again it will work. A couple of resistors were missing and the two control knobs were missing too!
I have yet to put this project together for waiting for the resistors (re-orders from DigiKey), but I expect it will be successful once everything arrives.
I would like to add this pre-assembled opinion in spite of my disappointment.
:Parts arrived in separate well wrapped bags, all parts are good quality also. Case is a well designed and executed piece of wood-work.
I had owned the Battery Powered preamp in the past and it was a very good performer, no glitches, not problems! So I expect this project to perform well also!
"Welborne, get your head screwed on right!"

Francis
  Reply With Quote
Old 22nd February 2014, 09:26 AM   #14
diyAudio Member
 
Join Date: Sep 2003
Location: London
STEVIE WONDER LYRICS - He's Misstra Know-It-All

Could be Stevie Wonder gets his kits from Welborne......
  Reply With Quote
Old 11th June 2014, 05:31 PM   #15
Edumar is offline Edumar  Brazil
diyAudio Member
 
Join Date: Nov 2004
Location: São Paulo
I'm also facing problems with Welbourne.
I bought an upgrade power supply 3 months ago, and after waiting for 2 weeks I contacted them and was informed that some components were missing in stock.
After a few more weeks without news, I contacted them again and was informed that they already had shipped the product, buy they never informed the tracking number.
Today I am still awaiting the arrival of the product, and my emails were not replied anymore.
I recommend extreme caution when making business with Welbourne. They are not trustable.
  Reply With Quote
Old 11th July 2014, 04:29 PM   #16
Edumar is offline Edumar  Brazil
diyAudio Member
 
Join Date: Nov 2004
Location: São Paulo
Don´t buy welbourne products !!!

After a long time waiting for my power supply, I finally received it.
Firstly, they lied about the shipping date.

This is the picture of the product that they offer to you:

Click the image to open in full size.

And this is what they really send to you:

Click the image to open in full size.
  Reply With Quote
Old 11th July 2014, 07:14 PM   #17
diyAudio Member
 
Join Date: May 2003
Location: USA
Second image not loading...
  Reply With Quote
Old 12th July 2014, 05:22 PM   #18
Edumar is offline Edumar  Brazil
diyAudio Member
 
Join Date: Nov 2004
Location: São Paulo
Is it loading now?

Thank you.
  Reply With Quote
Old 12th July 2014, 06:00 PM   #19
diyAudio Member
 
Join Date: Aug 2012
The second picture is located on another site for which you need an account.
Please upload the picture here so we all can see it.
  Reply With Quote
Old 12th July 2014, 07:17 PM   #20
Edumar is offline Edumar  Brazil
diyAudio Member
 
Join Date: Nov 2004
Location: São Paulo
Hope this will work now... thank you.

Click the image to open in full size.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Welborne Labs Horrible Service sbrtoy Parts 18 19th August 2008 02:20 AM
PASS LABS X-5 service maual ROLIKOV Pass Labs 0 24th May 2007 08:01 PM
The Pass Labs X2 - service manual Asen Pass Labs 14 19th September 2006 09:17 AM
california audio labs aria mk3 service manual zabaltegi Digital Source 1 13th May 2005 01:45 PM


New To Site? Need Help?

All times are GMT. The time now is 02:32 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2