testing 6550's on a Hickok 539b, same as KT88? - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st February 2011, 06:29 PM   #1
diyAudio Member
 
Join Date: Dec 2010
Location: Amesbury, MA
Default testing 6550's on a Hickok 539b, same as KT88?

I tested some 6550's with the KT88 switch settings because I could not find 6550 on the roll chart. I noticed when I pushed P4 that my digital plate current meter was throwing out some really bizarre readings. I do not think they are the same switch settings so if anyone has a 539b or 539c and can find the switch settings for a 6550 please let me know.

Thanks in advance
  Reply With Quote
Old 21st February 2011, 07:37 PM   #2
diyAudio Member
 
HollowState's Avatar
 
Join Date: Aug 2006
Location: Taxland, New Jersey
Even the latest (last) data chart (#3200-330) for the 539C does not list a 6550. I have always used the KT88 settings, in the foreign data supplment, with no problems and am confident they are correct. If you are experiencing trouble, I'd suggest a bad tube or bad connection somewhere.
__________________
"I regard the brain as a computer which will stop working when it's components fail. There is no heaven or afterlife for broken down computers. That is a fairy story for people afraid of the dark." ~Stephen Hawking
  Reply With Quote
Old 21st February 2011, 07:45 PM   #3
diyAudio Member
 
Join Date: Dec 2010
Location: Amesbury, MA
Thanks Hollow state! I think the tubes are faulty, I have always used KT88 switch settings before without problems. Just wanted a second opinion.

Thanks again!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! can't find ef86 on my Hickok 539b roll chart! and need a tube project famousmockingbird Tubes / Valves 4 18th February 2011 01:42 AM
Can't find 5y3 on Hickok 539b roll chart! famousmockingbird Equipment & Tools 5 4th January 2011 11:29 PM
FS: Hickok 539B Tube Tester Zero Cool Swap Meet 2 17th February 2009 06:15 PM
Interest in Hickok 539B/C Bias Pots?? Zero Cool Everything Else 0 8th November 2008 05:45 PM


New To Site? Need Help?

All times are GMT. The time now is 08:56 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2