diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Tubes / Valves (http://www.diyaudio.com/forums/tubes-valves/)
-   -   XiangSheng D-2020-KT88 (http://www.diyaudio.com/forums/tubes-valves/179900-xiangsheng-d-2020-kt88.html)

MicroMan 27th December 2010 09:07 PM

XiangSheng D-2020-KT88
 
1 Attachment(s)
Hi everyone.

First off - the credits. Thanks to everyone who has contributed to the Yaqin 5881 forum. I bought one a few years back, used it for a while, then it broke. But thanks to all the contributors on that forum, I have been able to fix it and have had several years enjoyment from it. Needless to say, right now its bust again ( loud buzzing and one of the 5881 tubes glowing bright purple ). But all I need to do is replace the 5881 output tubes, check the bias, and it will be up and running again.

However, I also have a XiangSheng D-2020-KT88. I got it for the looks. It's absolutely stunning with the four KT88's and the two 5Z4P rectifier tubes. But same story, bought it, used it for a while, then it broke. But no Forum, so no fix !

The symptoms were that it would run ok for about ten minutes.then there would be a loud rustling noise from the left channel, followed by a loss of volume. I did the usual test of swapping all the valves across, and found the issue had something to do with one of the 6L6 tubes. So I bought a few spares from flea bay and rather optimistically emailed the manufacturers asking for a circuit diagram. To my surprise they sent me one back. I'm not going to upload it as I respect their intellectual property, and they have been most helpful with my problems. However, if you do need a copy, get in touch with them yourself. They are helpful people.

Unfortunately, that's were I lost interest. I re-connected the Yaqin, and put the XiangSheng up in the attic to gather dust for a year or two. But when the Yaqin started playing up, I brought the XiangSheng back down and resolved to fix it.

Now I'm not a a complete wuss when it comes to electronic circuits, only my background is microprocessors and transistors. So I was a bit dubious about the high voltages. I invested in a pair of Marigold rubber gloves and decided to go for it.

Initially I just didn't get what the circuit was about. But I found a really good explanation of a simple KT88 valve amplifier at this site ....

Lenard Audio - Education - Valve Amps

The example output stage explained on this site is a dead ringer for the XiangSheng, and the technical explanation was pitched at just at the right level.

So first thing was to replace the noisy 6L6 tube. This got rid of the rustling noise, but the left channel would still loose all volume after 10 minutes or so. So I was looking for a second fault.
I checked off a few key voltages. According to the circuit diagram ...

B+1 voltage should be 560V, and is at start-up, but settles down to 508Volts as the tubes warm up.
B+2 voltage should be 380v, but settles down to 376v after warm up.
I did write down the heater voltage, but I've lost it. It was definitely well below 6.3v so didn't require the addition of any dropper resistors ( the Yaqin had required some major mods to drop the heater volts).

As I said earlier, I'm not an expert with valves, so I stuck to my limited experience with the Yaqin. Everyone on that forum is really keen to get rid of the original capacitors. So I did the same for the XiangSheng.

The XiangSheng sales literature bangs on about the capacitors being 'German red polypropylene' and lists them as one of the features. But guess what ? - mine were stuffed ! Replacing them with some audio grade polypropylene axial's from a well known mail order company fixed the volume issue. Then I tweaked the output bias following the instructions on the web site, and everything is now working fantastic.

An additional change I made was to replace the on/off switch with a self illuminating type. As you would expect, its not as simple as it seems. The existing switch is a two pole two way switch. But for some reason, both pole are connected to live. So I had to remove the existing wiring, and replace it with two wires ( live and neutral ) from the mains socket on the back panel to the switch on the front panel. From there, I ran the switched live and neutral cables back across to the transformer, where I added a chock block connector to make it all safe.

Also I spotted that the chassis ground was by means of a solder lug screwed to the steel cabinet. The thread on the screw had been stripped and wouldn't tighten, so the whole thing needed replacing.

So the D-2020-KT88 has been up and running for a few months now. During that time I've got a set of replacement tubes for the Yaqin, and its got to be said, that the Yaqin, with its ultra linear output stage definitely sounds the superior amplifier.

But which am I using right now? - the XiangSheng.
Why? - because it looks sexy.

One question though. The 6L6 tubes are running noticeably hotter than everything else. Is this normal ?

Cheers

MicroMan

AJT 28th December 2010 03:18 AM

Quote:

B+1 voltage should be 560V, and is at start-up, but settles down to 508Volts as the tubes warm up.
B+2 voltage should be 380v, but settles down to 376v after warm up.
I did write down the heater voltage, but I've lost it. It was definitely well below 6.3v so didn't require the addition of any dropper resistors ( the Yaqin had required some major mods to drop the heater volts).
i am mo expert either, but 560 settling to 506 is not really a big deal, possibly lower power, neither is 380 to 376, nothing to lose sleep about.....

nominal heater voltage of 6.3 can be between 5.9 and 6.9 anything in between is fine and will be a function of your line voltage.....

capacitors are like religion, there are generics of mylar or polypropylene, depends on what you like.....they are the least of my worries....:)


All times are GMT. The time now is 06:38 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2