miniblok 2 distorted sound - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th October 2010, 01:57 AM   #1
diyAudio Member
 
Join Date: Feb 2010
Location: calgary alberta tundra canada
Default miniblok 2 distorted sound

i built this amp but the sound is distorted is it because i used the wrong PP OT?

the one i used is rated at 10watts 10k and 60H.

both amps are distorted so i assume it's something in common to them. the design calls for a OT with 28 and 42 - 1 windings i'm not sure how this applies to this OT.

any help would be appreciated

thanks
Attached Images
File Type: gif mniblok2.gif (11.0 KB, 70 views)
  Reply With Quote
Old 7th October 2010, 02:51 AM   #2
kevinkr is offline kevinkr  United States
diyAudio Moderator
 
kevinkr's Avatar
 
Join Date: Sep 2004
Location: Boston, Massachusetts
Blog Entries: 6
Do some voltage measurements (B+, cathode voltages, grid voltages) and let us know the results. I once swapped center tap and the outer leg of the primary in an amp I was building, dc voltages measured fine, the amplifier behaved very strangely to put it mildly..

Is the -15V correct? The output section of each triode is operated with combination bias. (Both fixed and cathode bias) You did not swap the sections did you because these are dissimilar triodes. (Probably obvious, but best to know)

I don't think the transformer is the issue here, if anything the higher primary Z would result in somewhat lower power, higher damping factor and probably a little less distortion..

Do you have scope and a generator?

Some pictures of your build may help as well..
__________________
"Extraordinary claims require extraordinary evidence." - Carl Sagan

Last edited by kevinkr; 7th October 2010 at 02:57 AM.
  Reply With Quote
Old 7th October 2010, 03:52 AM   #3
diyAudio Member
 
Join Date: Feb 2010
Location: calgary alberta tundra canada
thanks kevin

the B+ voltge is too low and the tank caps drain but without the tubes in they hold a good charge so i guess i made a wiring error and repeated it in both builds. i would like to post a pic but no cam.

im only getting 10.5 volts where it should be 15. probably where the problem is

it's good to know the OT is alright. the amp sounds really good in essence very accurate just need to get rid of the distortion. ill go over the wiring again tomorrow. maybe i have the zener in backwards or something
  Reply With Quote
Old 7th October 2010, 05:57 PM   #4
diyAudio Member
 
Join Date: Feb 2010
Location: calgary alberta tundra canada
fixed it. some shielding was shorting out the circuit. nice sounding project, highly recomended
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Akai AM-37 problems - distorted sound dovilis Solid State 3 21st August 2010 05:34 PM
Arcam delta 290 p working but distorted sound homertooties Solid State 3 21st September 2008 05:31 PM
Questions about tweaking the Miniblok SET... 69CamaroSS396 Tubes / Valves 11 9th August 2008 09:37 PM
NAD AMP.....sound distorted....fuses blown linton Solid State 10 11th November 2006 07:36 AM
sound distorted from Jolida JD100H maya1 Digital Source 0 11th June 2004 11:34 AM


New To Site? Need Help?

All times are GMT. The time now is 07:48 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2