Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st February 2010, 04:16 PM   #1
Svein_B is offline Svein_B  Norway
diyAudio Member
 
Join Date: Oct 2005
Default LtSpice - Russian tube models

I spent some time looking for Spice models for the the GU50.

I managed to find some Russian tube models here, including the GU50: audioportal.su/showthread.php?t=7020

I am however not able to get the models to work in LtSpice.
It seems the tetrode/pentode models have the electrodes in a different order than the LtSpice symbols from DuncanAmps, and I do not know how to fix this.

More strange; the triode models seem to have the pins in the right sequence, but they do not work either.

Svein
Attached Files
File Type: zip PSlib.zip (3.5 KB, 240 views)
  Reply With Quote
Old 21st February 2010, 06:34 PM   #2
Svein_B is offline Svein_B  Norway
diyAudio Member
 
Join Date: Oct 2005
Update:

The triode model works.
Must have been a "hick-up" in LtSpice that showed wrong current, in the wrong direction through R2. Deleted and re-inserted resistors and it works.

For the pentode I have temporarily defined a new symbol with nodes in same order as the model.

Svein
Attached Images
File Type: gif Spice-traces-gu50.gif (14.1 KB, 538 views)
  Reply With Quote
Old 22nd February 2010, 12:48 AM   #3
diyAudio Member
 
Join Date: Mar 2003
Location: NYC
how did you log on and download the files? I see there is a Tetrode 6E5P that I would love to have.

dave
  Reply With Quote
Old 22nd February 2010, 02:24 PM   #4
Svein_B is offline Svein_B  Norway
diyAudio Member
 
Join Date: Oct 2005
I did not log on and download the files stored on the forum, but I did a little bit of Internet Archeology;

I tried to follow a link to to a page which was no longer existing, but archive.org had a copy.

With the added help of Google translate we get this page: Next-Tube. Design of vacuum tube audio amplifiers
Here we find the PSlib.zip file that I attached to in post#1.
There is also a file Tube_ORCAD.zip that has a larger library which also include the 6E5P

Svein
  Reply With Quote
Old 22nd February 2010, 02:46 PM   #5
diyAudio Member
 
Join Date: May 2007
Hey,

I found the libraries a long time ago but gave up due to I couldn´t make them work.

Svein, could you link the *.asc and the *.asy for the reworked tetrode?
  Reply With Quote
Old 22nd February 2010, 06:10 PM   #6
Svein_B is offline Svein_B  Norway
diyAudio Member
 
Join Date: Oct 2005
revintage:
To create a symbol to work with the models in tubes_IM.inc, just open the existing tetrode symbol and edit the pin number assignment so that
P G1 C G2 correspond to 1 2 3 4. Make it look a little different, and save it under a different name.

Attached is the symbol I used (tetrode-Ry.asy)

Svein
Attached Files
File Type: zip tetrode-Ry.zip (542 Bytes, 164 views)
  Reply With Quote
Old 23rd February 2010, 01:14 AM   #7
diyAudio Member
 
Join Date: Mar 2003
Location: NYC
Thanks Svein!

Got the files and the triode models are fine. The only tetrod I tried was the 6E5P and I keep getting the error below. I tried reworking both the model and the symbol and keep getting this result. I'll try with the GU-50 to see I I can replicate your results.

dave

Click the image to open in full size.
  Reply With Quote
Old 23rd February 2010, 08:00 AM   #8
Svein_B is offline Svein_B  Norway
diyAudio Member
 
Join Date: Oct 2005
I found that the pages of Eugene Karpov that I linked to in post#4 are available and active at a new address, and in English language, so no need to use archive and translate.
Next-Tube. Design of vacuum tube audio amplifiers.

Lots of good stuff there.


Dave,
the error message you posted is typical if you use a triode symbol (3 pins) and a spice model value for tetrode (4 pins)

Svein.
  Reply With Quote
Old 24th February 2010, 02:22 AM   #9
diyAudio Member
 
Join Date: Mar 2003
Location: NYC
Svein,

still no luck with the pentode.

Lars, have you made any progress? I'm reasonably sure it is a simple pin renumbering thing but I am still striking out.

dave
  Reply With Quote
Old 24th February 2010, 07:29 AM   #10
diyAudio Member
 
Join Date: May 2007
Hey dve,
Will have another go at it soon. 6J9P/E180F is the one I will try to get working...
The 6E5PT model we discussed at your forum is good enough. But the tetrode would be nice to have!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ltspice and Valve models Melon Head Tubes / Valves 3 18th October 2009 08:35 AM
Need help with tube models in LTSpice Bitrex Tubes / Valves 5 6th August 2009 07:28 PM


New To Site? Need Help?

All times are GMT. The time now is 09:05 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2