my TubeLab Amps - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 22nd August 2009, 07:12 PM   #1
diyAudio Member
 
Join Date: Oct 2004
Default my TubeLab Amps

TubeLab SSE for 6L6 and EL-34: Hammond 373BX, Hammond 193H, ASC 50uf, One Electron UB2 OPTs running Siemens EL-34
Attached Images
File Type: jpg SSE for 6L6 and EL 34 (Medium).JPG (76.9 KB, 504 views)
  Reply With Quote
Old 22nd August 2009, 07:13 PM   #2
diyAudio Member
 
Join Date: Oct 2004
TubeLab SSE foe 6550 and KT88: Hammond 374BB, Hammond 193H, ASC 50uf, Transcendar OPTs running SED6550
Attached Images
File Type: jpg SSE for 6550 and KT 88 (Medium).JPG (78.5 KB, 487 views)
  Reply With Quote
Old 22nd August 2009, 07:14 PM   #3
diyAudio Member
 
Join Date: Oct 2004
TubelabSE: Hammond 370HX, Hammond 193J, 70uf ASC, Electraprint 15w OPTs running JJ 300B
Attached Images
File Type: jpg SE in Action (Medium).JPG (84.8 KB, 473 views)
  Reply With Quote
Old 22nd August 2009, 07:14 PM   #4
diyAudio Member
 
Join Date: Oct 2004
All Together Now
Attached Images
File Type: jpg All together (Medium).JPG (77.9 KB, 466 views)
  Reply With Quote
Old 22nd August 2009, 07:25 PM   #5
Salas is offline Salas  Greece
diyAudio Chief Moderator
 
Salas's Avatar
 
Join Date: Oct 2002
Location: Athens-Greece
Nice. Can you tell us more about living with them and driving your several speakers? A mini review, comparison, best on what speakers, etc.
  Reply With Quote
Old 22nd August 2009, 07:29 PM   #6
diyAudio Member
 
Join Date: Jan 2007
Location: Minnesota
Very Nice...what wood did you use for the 6l6 tubelab SSE amplifier?
  Reply With Quote
Old 22nd August 2009, 07:31 PM   #7
diyAudio Member
 
Ty_Bower's Avatar
 
Join Date: Mar 2007
Location: Newark, DE
Really nice looking amps! I especially like the woodwork. You've got your output transformers backwards on the first two, though.

Last edited by Ty_Bower; 22nd August 2009 at 07:33 PM.
  Reply With Quote
Old 23rd August 2009, 08:06 AM   #8
diyAudio Member
 
Join Date: Oct 2004
Thanks a lot guys. Salas, haven't had much time with them. I use the KT88 amp with my Bozak 301s and sounded very good. The other amps (300B and El-34s) were used on th BIBs. The 300B amp is much more detailed and sweeter than the other 2 but the one with the Transcendar OPTs really surprised me with how much bass quality it can produce and detail approaching that of the 300Bs.

Paul, no idea what wood is that. I just picked it up from my garage stash.

Ty, you have a very keen eye. Ther transformers were installed as such intentionally so that the nuts of the transformer bells are located towards the rear.

Before I forget, to TubeLab George; thanks for this design. To Russ W. Knize; thanks for all your help and patience with me. I owe you a lot of wisdom in building these amps.

Godspeed.

John Revilla
  Reply With Quote
Old 23rd August 2009, 08:40 AM   #9
diyAudio Member
 
Ty_Bower's Avatar
 
Join Date: Mar 2007
Location: Newark, DE
Quote:
Originally Posted by Doc Jr 8156 View Post
Ty, you have a very keen eye. Ther transformers were installed as such intentionally so that the nuts of the transformer bells are located towards the rear.
Not quite what I meant. You said the EL34 amp has the One Electron UB2 transformers, and the 6550 amp has the Transcendars. I think you've got that backwards.
  Reply With Quote
Old 23rd August 2009, 04:36 PM   #10
diyAudio Member
 
Join Date: Oct 2004
Hi Ty,
You were right. The labels were switched. Godspeed.

John Revilla
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tubelab...Why "sandy" SE amps? Richard Ellis Tubes / Valves 15 19th June 2008 05:30 PM
Question regarding PS ripple in guitar amps - TubeLab? LowRedMoon Tubes / Valves 8 30th April 2008 02:03 PM
tubelab PP? weinstro Tubes / Valves 9 25th March 2008 04:07 AM
Especially for Tubelab: 845 amp 2.0 Giaime Tubes / Valves 24 30th July 2006 04:39 PM


New To Site? Need Help?

All times are GMT. The time now is 07:54 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2