diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Tubes / Valves (http://www.diyaudio.com/forums/tubes-valves/)
-   -   Oscillation in tube amps (http://www.diyaudio.com/forums/tubes-valves/145103-oscillation-tube-amps.html)

tubelab.com 1st June 2009 12:50 AM

Oscillation in tube amps
 
There have been many questions asked about oscillation in tube amps. These have been scattered across so many different threads that the search engine can't find them all. I am starting this thread to collect the thoughts in one place.

I am doing this because I was searching for something else last week and I found an old thread where someone had asked me how I check for oscillation. I realized that I never saw that question so I posted the answer, but the original poster may have not seen it since the question was buried in a non related thread.

Now I am working on some new circuits and I captured an oscillitory gremlin hiding in my amp. It is the evil hard to catch kind. I have not found the cause yet, and with my current work schedule, it might take a couple of weeks.

I am copying the original questions and answers in the next post.

tubelab.com 1st June 2009 12:55 AM

Quote:

As for oscillations: I always thought the cause was unterminated resonant stubs. Low impedance on one end, high impedance on the other, and a quarter length "whip antenna" of some resonant frequency. Then you abuse the high voltage/high impedance/low current end of that resonant antenna stub as one of the control elements of a tube or FET, and let it pick up stray garbage from the amplified output. Or high impedance both ends, and resonant on the half wave...
Sometimes it is just stray capacitance resonating with leakage (and other unwanted) inductances being excited by the abrupt spike created when an output tube is driven to cutoff. Some circuits just want to oscillate. Some circuits may exhibit some oscillitory instability without the user being aware of it. I tend to "sniff" my tube circuits with an RF spectrum analyzer while driving them to clipping. My full time job is transmitter design, so it is just a habit.


Quote:

Does pass/fail RF oscillation test typically require sensitive front end amplification at such close range?.
I mean, if a tube is gonna oscillate, gonna oscillate BIG, right?
Also have plenty of attenuators on hand if needed...
Some circuits may rudely oscillate at an RF frequency while still doing a reasonable job of passing audio. The oscillation is more or less continuous, and may cause distortion, or a vague foginess in the sound. Sometimes there are no audible artifacts. These can often be detected with an AM radio or TV set in the same room. Often one or two TV channels are totally wiped out even though the TV is connected to cable and recieving a strong signal. Often moving parts around will change the affected channel, and help lead to the offending circuit. These are the easy ones.

More often a circuit may breifly emit a burst of RF energy only under certain conditions, often as one tube in a P-P amp cuts off or returns to conduction, or at the onset of clipping. Sometimes this can be seen on a scope. I use an old HP 141T spectrum analyzer with a 0 to 1250 MHz RF unit. I "sniff" with a piece of coax that is stripped back exposing about 2 inches of the center conductor. The entire end is covered with heat shrink to prevent accidental contact with a live circuit. I do not use an additional LNA since the 2 inch wire will pick up local TV, radio and cellular towers.

Operate the amplifier with an oscillator and a load resisitor and with a real speaker and music. Drive the amp to clipping, while "sniffing" around. The best places to find anything is right next to each tube. I usually crank the amp hard with some bass heavy music and look for anything at all on the spectrum analyzer that pulsates in time to the bass. I set the analyzer to scan zero to 50 or 100 MHz at maximum RF sensitivity. Even with the small "antenna" you will find all sorts of signals that vary as you probe around inside the amp. Welcome to our RF polluted environment. In my case TV channels 2 and 4 (analog) are very strong. So is the local high school radio station at 88.5 MHz. Find anything suspicious? Without moving the probe, shut the amp off and see if it goes away.

tubelab.com 1st June 2009 01:27 AM

2 Attachment(s)
I have been working on my "universal driver board" on and off since late last year. Before my recent trip I had been testing the first prototype with various output tubes in screen drive and conventional grid drive. No anomalies have been seen but all testing has been on the bench with test equipment and a load resistor. No listening tests were done since I only had about one week to work with the board before I had to make a long road trip. The last test was a pair of VT225 / 307A tubes in triode wired P-P using conventional grid drive. 30 watts comes easy with this design in AB2. Hard clipping is near 40 watts.

Tonight I turned the power on for the first time in 3 weeks and the amp still worked. The scope traces were clean even when pushed well into clipping. OK now it's time to listen. Righe now there is only one channel, and it is operated by 4 seperate bench power supplies. There are clip leads for connection to the output tubes and power supplies. I connected my speakers in parallel and wired them to the 4 ohm tap, attached the CD player and cranked it up.

The amp sounds nice but the bass is a little loose. Maybe a small amount of feedback will tighten it up, but I am not going to try that now. I played some different music while turning the knobs. I found that the amp sounded better by reducing the B+ from 380 to 350 volts and turning the tube current up to 75 mA each, yeah way over the line. This tightened up the bass considerably. I can play Depeche Mode pretty loud now, and Diana Krall is sitting on top of my speakers (mono remember).

I was cranking Diana way into the clipping zone and her voice cracked. This is not right. The piano cracked too. It doesn't sound like typical distortion, it sounds like...... the gremlin!

I connected the storage scope right across the speaker and kept pressing the save button until I caught one. It is interesting that cranking the amp with rock, techno, or any other complex music doesn't seem to cause it.

The picture is a single piano note pushed into clipping from the intro to Diana Krall's rendition of "How can You Mend A Broken Heart" off of her latest CD. Note the ringing in the flat topped portion of the wave. This is a high frequency oscillation that occurs briefly as the amp clips. It does not do this with the same music and a load resistor. A speaker must be used. It does not happen if the amp doesn't clip. In fact it doesn't happen on gentle clipping. The oscillation either happens, or it doesn't. It doesn't change level or get worse if the volume is turned up more, it just happens more often.

I plan to investigate this more thoroughly and report my findings here. My usual gremlin hunting tools like the AM radio, the TV, the scope, and even the spectrum analyzer will be used.

PB2 1st June 2009 02:01 AM

I've been thinking recently (the past few years) that it makes a lot of sense to put an RC damper on the secondary of the OT. Just to provide some reasonable HF load rather than the pure (more or less) inductance from the tweeter or whatever driver.

Have not tried it. Surprised that this is not seen more in tube amps. I have only seen a few commercial designs where it is done.

Pete B.

tubelab.com 1st June 2009 02:44 AM

2 Attachment(s)
Quote:

It is interesting that cranking the amp with rock, techno, or any other complex music doesn't seem to cause it.
After playing the entire Violator CD at far too much volume I have found that the gremlin can be coaxed out of hiding with some more complex music. It doesn't happen as often and you have to be far enough into clipping that I had to put the speakers in the bathroom and close the door. It sounds nasty, turn that s*** down kind of nasty. You would not listen to this, so I never heard it during the first listening session. I captured one instance of the gremlin on the scope with Depeche Mode's "Policy of Truth."

Later I found that brief transients seem to be the worst offenders. The single piano notes mentioned before can be played far enough into clipping to bring out the gremlin, but not yet sound bad, so the effect is audible. The worst offender? Enya. Her brief staccato orchestra hits on "Orinoco Flow" can be played loud enough to invoke the gremlin on every note, but oddly enough he is just barely audible.

Its 10:30 PM, and I have annoyed the neighbors enough tonight, so all is silent now.

I have a new version of this PC board all done in my computer. I am debating whether to continue chasing this down on this board, or stop and make one of the new ones. Either way it will likely wait till next weekend.

Quote:

it makes a lot of sense to put an RC damper on the secondary of the OT
This is common practice in SS amps. I will have to try it here to see if it makes any difference.

tomchr 3rd June 2009 06:34 PM

I've seen these kinds of oscillations in sand amps. Weird stuff happens as transistors enter and recover from saturation. Weird enough that op-amps have circuitry built in to make the performance in/near saturation more graceful.

I'm not entirely surprised to see it in a tube amp, but it is surprising (at least to me) that it's random in nature.

Are you able to reproduce it with any of the normal test waveforms (square wave in particular)?

~Tom

jon_010101 3rd June 2009 07:24 PM

This is a very interesting thread! Maybe it is happening at frequencies near the loudspeaker's crossover (i.e., female vocals)? :confused: Perhaps try adding a compensation network to flatten out the speaker's impedance? I have always wondered if my speakers provoke my tube amps in this way.

m6tt 3rd June 2009 08:20 PM

In terms of a resource for others, especially those without test equipment, I've found any of the following to be fairly indicative of an oscillation:

1. Harsh, grainy high frequency response
2. Strange noises at turn-on/turn-off (Squeals, all manner of other strange sounds)
3. Sometimes biasing wierdness or one tube working much harder than the other at idle (sometimes can cause hum, I think)
4. Motor-like sounds
5. Hissiness or sudden harshness at full or near full volume
6. Lots of AC on the plates with no sound coming out
7. The amp suddenly stops playing, particularly after just having clipped
8. "Clicking" -- I hear this one every once in a while, I'm not sure what it's all about, but generally anti-oscillation practices & anti-RFI have stopped it
9. Cats (max 64khz) or dogs (40-60khz) act weird around the amp, when they don't around others or playing similar music/sounds.
10. Scan with shortwave or AM radio to taste to try to identify strong signals only present when amp is on (not always easy)

Those are all that I can think of right now, the cat/dog one is my favorite, I discovered it accidentally while fixing a guitar amp...I turned it on and a dog ran from the other room into the amp room and started staring at the speaker. Ah ha!

robertaudio 19th June 2009 05:16 PM

oscillation can happen if the Amp has ALL the following conditions;
1. Gain too high
2. Positive feedback path.

Eliminate any of the conditions and oscillations will go away.

Robertaudio


All times are GMT. The time now is 10:23 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2