Help restore an RCP 413 tube tester - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th December 2008, 05:10 PM   #1
diyAudio Member
 
Join Date: Sep 2006
Location: Malta, Europe
Default Help restore an RCP 413 tube tester

Hi all, I'm not sure this is the right forum...., but I couldn't find any better! Is anyone here familiar with this Radio City Products tube tester? It must be over 60 years old and I'm restoring it. A circuit diagram is attached below.

While giving it a thorough clean-up and varnishing the wooden case, I changed the capacitor (C1) to .047uF/400V and fitted the neon lamp which was missing. A new mains cable was also fitted. I checked the other components (resistors, rheostat, pots.) and the meter and they all measure OK.

The first three functions of the tube tester (i.e. (a) Short and Leakage test, (b) Filament Continuity and (c) Cathode Leakage) are performing properly. When I do the Quality Test (following the instructions on the owner's manual) the meter pointer remains static at 0 (lowest level of 'poor' quality!!).

I tried several valves (all octals, known to be working - there is no provision for 9-pin valves (!), but I intend to insert one), and not one of them managed to move the meter pointer...!! I checked the valve-holder for possible wire breaks; - nothing.

Can anyone help with ideas or suggestions.

Thanks in advance.

Joe A
Attached Images
File Type: jpg rcp 413 circuit.jpg (32.6 KB, 47 views)
  Reply With Quote
Old 11th December 2008, 05:30 PM   #2
diyAudio Member
 
Join Date: Sep 2006
Location: Malta, Europe
Default Problem solved!

The phone jack socket was not making contact -- open circuit.

For members with similar problems with test gear I can recommend this site:
http://www.vintage-radio.net/forum/index.php.

Regards to all.
Joe A
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tube Tester's Space1 Tubes / Valves 17 2nd June 2009 09:54 PM
Tube Tester jtwrace Tubes / Valves 5 8th September 2007 05:47 PM
Tube tester Sjef Tubes / Valves 6 29th January 2007 09:38 PM
tube tester TJ Tubes / Valves 11 5th April 2005 03:23 PM
help using Tube Tester ebarker2 Tubes / Valves 3 31st January 2004 03:30 AM


New To Site? Need Help?

All times are GMT. The time now is 12:34 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2