diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Tubes / Valves (http://www.diyaudio.com/forums/tubes-valves/)
-   -   Gibson Ga-20 rvt reverb problems (http://www.diyaudio.com/forums/tubes-valves/132934-gibson-ga-20-rvt-reverb-problems.html)

blindbrett 10th November 2008 08:14 PM

Gibson Ga-20 rvt reverb problems
 
I have just received a mid 60's gibson minuteman amp and the reverb doesn't work. I have an open secondary on the reverb driver transformer ( part # E-6400) and an open input coil in the reverb tank (no part #). I was wondering if anyone had the reverb driver transformer specs and the reverb tank part number or specs. I found a replacement transformer at Mercury Magnetics but it is a bit pricey and I have heard that people have used old tube radio output transformers with good results. My only problem is that I don't know what the transformer specs are or what the impedance of the tank are. if anyone can help, I would greatly appreciate it.

Best Regards

Brett

guitar88 11th November 2008 03:18 PM

The reverb circuit in the GA-20 is a whole lot different than the fender circuit. My recommendation is to use the Fender reverb transformer and the Fender tank. These can be purchased from Antique Electronic Supply. The transformer is part number P-TF22921 at $14.95 and the tank is the 8 ohm to 2250 ohm 4AB3C1B their part number P-R4AB3C1B at $24.95.

I have a 1964 GA-77RTV Vanguard and these Gibson amps are pretty good sounding.


All times are GMT. The time now is 06:47 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2