Ripple filtering help... strange slow rise and fall of voltage - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st August 2008, 05:26 PM   #1
jlw is offline jlw  United States
diyAudio Member
 
Join Date: Apr 2007
Default Ripple filtering help... strange slow rise and fall of voltage

Greetings,

I wonder if I could solicit some assistance from fellow DIYers.

Attached please find a picture of the rectifier/filter section of a Ming Da MC-2A3 preamp before it goes to regulation.
(Oh well, I can't seem to upload the picture but its here:
http://www.audioasylum.com/cgi/t.mpl?f=amp&m=133536
)

The problem I am seeing is that while the general AC ripple level across the right-most filter caps (they are balanced with bleeder resistors) is almost unmeasurable, I see regular rise and fall of voltage (1/4 to 1/2 a second per rise/fall but not even) on my scope, in additon to spikes up to 25mV at times.

Measuring across the 1st 2 caps as expected shows AC ripple but
the absolute voltage does not seem to drift up and down.

Measuring the ripples across the 20H choke also shows only AC ripples but no up and down in absolute voltage.

I have changed out the caps to known good Nichicons but the problem remains. I have also disconnected the regulator and measured the across the right most caps with the same results.

Any suggestions and opinions welcome.
Thanks for your time.
  Reply With Quote
Old 22nd August 2008, 12:29 AM   #2
diyAudio Member
 
Join Date: May 2005
Location: Stittsville, Ontario, Canada
I dont necessarily see a problem here. 25mv before the regulator does not sound too bad to me. The regulator may be quick enough to catch it. Have you measured the spike after the regulator ?

Also the circuit is going to have a certain amount of power supply rejection, 25 mv on the main B+ may not result in an audible effect. When the spikes occur, do you hear anything ?

I realize that it would be good to know the cause of the spikes and rise and fall of voltage even if there is no audible effect.

I may be off base here, you may have a very solid test set up, but sometimes when I get results like those you describe I find out it is my scope probe connections that are flakey, ie the probe moving around on the terminal and producing fluctuations. I end up re-routing all my leads and duct taping them to the bench, and then all is well.
__________________
Robert McLean
  Reply With Quote
Old 22nd August 2008, 04:52 PM   #3
jlw is offline jlw  United States
diyAudio Member
 
Join Date: Apr 2007
Default Thanks Robert

I ended up disconnecting things 1 stage at a time and found that either 1 or both 1st stage filter caps right after the choke was faulty and making noise. A view on the scope of voltage across that cap is outright horror. Disconnected the 2 caps, checked the waveform after the choke and its the expected ripples.
So I got 2 470uF 450v Nippon Chemicons of the same size from the local surplus store, swapped them in, and no more weird spikes and drops. Reconnected the downstream choke and caps and regulator and while I still have a bit ( a few mV) of rise and fall at regular intervals I have no more noisy spikes and it's a lot better now. THANKS!!!
  Reply With Quote
Old 22nd August 2008, 05:54 PM   #4
GordonW is offline GordonW  United States
diyAudio Member
 
GordonW's Avatar
 
Join Date: Mar 2005
Location: Marietta/Moultrie GA
I wonder what the resonant frequency of the combination of the first choke and first cap is, and what the resonant frequency of the combination of the second choke and second cap is. If they're too close together, you might be getting a sort of "mutual resonance" between them, that's causing that ultra-low frequency 'waveform' you're noticing. I've seen that effect, sometimes, modeling stuff in PSUDII, in fact... and usually, if you change one of the values (a choke or a cap) a bit, it can usually be made to basically go away...

That, IME, can be one drawback of using big caps... you can get high-Q resonance between them and a choke.

If that's the case, it might be "damped down" by using more aggressive bleeder resistors (lower resistance, to draw a bit more current and apply more 'damping'), or a small resistance in series with one or both of the chokes (like maybe 50 ohms)...

Regards,
Gordon.
__________________
Speaker Design, Restoration and Repair- since 1985.
  Reply With Quote
Old 22nd August 2008, 06:21 PM   #5
diyAudio Member
 
Ty_Bower's Avatar
 
Join Date: Mar 2007
Location: Newark, DE
Default Re: Thanks Robert

Quote:
Originally posted by jlw
A view on the scope of voltage across that cap is outright horror.
I've sometimes wondered what is the proper method for checking high voltage with the oscilloscope. I assumed I can't just stick my 'scope probe on the 450 volt rail.
  Reply With Quote
Old 22nd August 2008, 06:54 PM   #6
pchw is offline pchw  United States
diyAudio Member
 
Join Date: Apr 2006
Location: Fremont, California
Default Re: Thanks Robert

Quote:
Originally posted by jlw

So I got 2 470uF 450v Nippon Chemicons of the same size from the local surplus store, swapped them in, and no more weird spikes and drops. Reconnected the downstream choke and caps and regulator and while I still have a bit ( a few mV) of rise and fall at regular intervals I have no more noisy spikes and it's a lot better now. THANKS!!!
Hey jlw,
OT is little, which surplus store did you go to? For some reasons, I don't seem to have any luck to find them in Bay Area.

Thanks!!
__________________
- Fred -
  Reply With Quote
Old 22nd August 2008, 07:16 PM   #7
Svein_B is offline Svein_B  Norway
diyAudio Member
 
Join Date: Oct 2005
Default Re: Re: Thanks Robert

Quote:
Originally posted by Ty_Bower

I've sometimes wondered what is the proper method for checking high voltage with the oscilloscope. I assumed I can't just stick my 'scope probe on the 450 volt rail.
I do.

As I remember the Tek scopes are specified for around 250V DC mode, and 500V AC. With 10x probe maybe even more.


SveinB
  Reply With Quote
Old 30th August 2008, 05:50 AM   #8
phi70 is offline phi70  United States
diyAudio Member
 
Join Date: Oct 2006
Default Thanks to all who took the time

to give me suggestions.
Yes... 450V across 2 caps in series is dang hard for some scopes and even with the 10x probe my entry level Velleman scope fried and wont calibrate after a few measurements.
Needed to take the pre to a friend's who's got a Tektronics.
Regarding that ultra low frequency ripple...
I got rid of some spikes by replacing the 2 noisy caps after the 1st
choke and now my next step is to increase the value of that to perhaps 560uF (or should I be so bold to try 820uF) so that it's not too close to the 470uF Nichicons I am using after the 2nd choke. Not sure if too high a capacitance might cause my
2A3 rectifiers to arc or not (there's a choke separating rectifier and 1st stage filter).
BTW I got the 470 uF 40mm diameter guys from HSC Electronics in Santa Clara, CA. Cheap cheap @ $4.95 each
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to determine ripple voltage? beerman Power Supplies 4 21st February 2007 07:27 PM
OpAmp specs: slew rat vs. rise/fall time rtarbell Parts 2 6th December 2005 04:38 PM
Aleph ripple voltage Pumuckel Pass Labs 11 10th November 2003 10:06 AM
How low should PSU ripple voltage be in a preamp? DrewP Tubes / Valves 5 6th February 2003 07:43 PM
How to improve rise/fall times from crystal oscillator? KasperM Digital Source 3 26th September 2002 04:22 PM


New To Site? Need Help?

All times are GMT. The time now is 12:17 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2