Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th June 2008, 01:11 AM   #1
diyAudio Member
 
Join Date: Mar 2006
Location: Michigan
Default Fostex Meets Pentode I need some NFB

Hello,

I just wired my EL34 Simple SE amplifier in Pentode (from Triode) mode and it brought my FE127E bi-poles to life! but I notice two things

1. The sound is most defiantly less Linear
2. There is more distortion

So I wanted to add a little (3-9db) of NFB to smooth everything out, except, I have no clue how to properly add such feedback, all I know is that It involves putting a resistor from the secondary on the OPT to the Cathode of the driver stage, but I don't know any of the rules!

please help, because I'm fairly sure adding NFB is stupid easy once you figure it out.

Thanks

Moose
  Reply With Quote
Old 18th June 2008, 01:44 AM   #2
diyAudio Member
 
Miles Prower's Avatar
 
Join Date: May 2005
Location: USA
Blog Entries: 6
Default Re: Fostex Meets Pentode I need some NFB

Quote:
Originally posted by alexmoose
I just wired my EL34 Simple SE amplifier in Pentode (from Triode) mode and it brought my FE127E bi-poles to life! but I notice two things

1. The sound is most defiantly less Linear
2. There is more distortion
Yep, that's gonna happen. I never did anything with EL34s, and don't know exactly what you're getting there. With pentodes, you will get more h3 and higher order harmonics that'll make anything from an excessively "edgey" or "aggressive" sound to something really annoying. You will definitely be needing some gNFB to tame that.

Quote:
So I wanted to add a little (3-9db) of NFB to smooth everything out, except, I have no clue how to properly add such feedback, all I know is that It involves putting a resistor from the secondary on the OPT to the Cathode of the driver stage, but I don't know any of the rules!
Figuring it really is NBD:

Avcl= Avol / (1 + BAvol)

You first need to know what your open loop gain is. That would be from the input to the output at the secondary of the OPT. If you wanted 6db(v) of gNFB, then:

Avcl= 20log(Avol) - 6 (In db(v) )

Convert that back to actual gain:

Avcl= 10^(Avcl(dbv) / 20)

Then:

Avol / Avcl= 1 + BAvol

And solve for B, which will be the "gain" of the voltage divider formed from the Rf resistor connected between the OPT secondary and the cathode resistor.

When connecting this and testing for the first time, make sure you use a resistive dummy load in case Mr. Murphy wired it for positive feedback and makes the amp into a high powered square wave oscillator. Best not to use the speeks for this since it'll make onehelluva racket. If that's the case, simply switch the primary OPT leads to reverse the phasing.

Once you've gotten that straightened out, make sure you're not getting any RF or ultrasonic oscillations that'll require additional compensation.
__________________
There are no foxes in atheistholes
www.dolphin-hsl.com
  Reply With Quote
Old 18th June 2008, 05:15 AM   #3
diyAudio Member
 
Join Date: Mar 2006
Location: Michigan
Alrighty,

Avol = open loop gain = 36.6666667 =~37 (Measured) Does this make sense for an EL34 in pentode driven by an ECC85? I can re-measure with more imput signal if necessary

Avcl = (20 Log (37)) - 6 = 25.36

Avcl= 10^(25.36/20) = 18.54

B = 1/avcl - 1/avol

B = (1/18.54) - (1/37)= .0269???

Is this right?

where do I go from here?

I form a voltage divider between the OPT secondary, and this resistor?
  Reply With Quote
Old 18th June 2008, 06:31 AM   #4
diyAudio Member
 
Miles Prower's Avatar
 
Join Date: May 2005
Location: USA
Blog Entries: 6
Quote:
Originally posted by alexmoose
Avol = open loop gain = 36.6666667 =~37 (Measured) Does this make sense for an EL34 in pentode driven by an ECC85?
Yes. You lose a helluvalot of voltage across the OPT, which is working as a voltage step-down xfmr.

Quote:
Avcl = (20 Log (37)) - 6 = 25.36

Avcl= 10^(25.36/20) = 18.54

B = 1/avcl - 1/avol

B = (1/18.54) - (1/37)= .0269???

Is this right?
Yup.

Quote:
where do I go from here?

I form a voltage divider between the OPT secondary, and this resistor?
Now you make a voltage divider with the input end at the OPT secondary, and the output end at the cathode resistor, which must be unypassed for this to work. Then:

0.0269= (1 X Rk) / (Rf + Rk)

Solve for Rf.
__________________
There are no foxes in atheistholes
www.dolphin-hsl.com
  Reply With Quote
Old 18th June 2008, 11:23 AM   #5
diyAudio Member
 
Join Date: Mar 2006
Location: Michigan
okay, this seems to make sense, will my gain really drop by 6db? (a factor of 4), as well, I have seen in some designs, a small capacitor bypassing the Rf (like .01 mfd) is this a good idea?
  Reply With Quote
Old 18th June 2008, 01:28 PM   #6
diyAudio Member
 
Join Date: Mar 2006
Location: Michigan
okay, I found the time and I crunched the numbers

Rf = (Rk /.0269) - Rk


Rk = 475 ohms (taken from schematic)

Rf = (475/.0269)-475 = 17.18299 Kohms or 17.2k (for 6db)

Rf = (475/.0111)-475 = 42.31779 Kohms or 42.3 k (for 3db)


How beefy of a resistor does this have to be? I have some 15k 1/4watts, and a ton of 2.2ks at any wattage you can think of.
  Reply With Quote
Old 18th June 2008, 06:05 PM   #7
diyAudio Member
 
Miles Prower's Avatar
 
Join Date: May 2005
Location: USA
Blog Entries: 6
Quote:
Originally posted by alexmoose
okay, this seems to make sense, will my gain really drop by 6db? (a factor of 4), as well, I have seen in some designs, a small capacitor bypassing the Rf (like .01 mfd) is this a good idea?
Yes, adding 6db(v) of gNFB will cut the open loop gain in half, just like you calculated before.

The reason for paralleling the feedback resistor with a capacitor is to enhance high frequency stability by rolling off the high end gain. So far, I haven't found this necessary since I'm using RF coax to lead the feedback from the output back to the input, and its inherent capacitance may be doing the compensating. This is one thing you have to determine by o'scoping to see if there's any hint of high frequency oscillation or damped oscillations.

Usually, you see this where the feedback factors are a good deal higher.

Calculate the power dissipated in the resistor with the usual formula: P= V^2 / R and get a resistor at least twice that power rating.
__________________
There are no foxes in atheistholes
www.dolphin-hsl.com
  Reply With Quote
Old 19th June 2008, 12:24 PM   #8
diyAudio Member
 
Join Date: Mar 2006
Location: Michigan
I wired it up for 3db, checked all my wiring, and gave it a go. Due to the legitimate concern that it would convert from an amplifier to a "high efficiency" square wave oscillator, I wired it up to my old junky speakers I found in a garage. The amplifier warmed up, and on the first try delivered some Pentode tunes with lower distortion, and improved linearity (qualitative observations made on a $10 pair of speakers). I checked the operating point of the tube, and everything seemed okay.

When I plugged the pentodes into my Fostex bi-poles, I noticed that the sound was just plain terrible, distortion was still high, sibilants sounded like sandpaper.

I decicded to remove the crossover cap I use two identical drivers in series (FE127) with a capacitor in between them to shunt high frequencies to ground, this way, all of the high frequencies goes into the front driver, while the baffle step correcting low frequencies get spit out both drivers. This makes the speaker itself behave somewhere between an 8 and 16 ohm load.

I removed the capacitor, and wired the drivers in true series with each other, and powered up. I hear music for a few seconds, then a putrid oscillation somewhere between 15 and 20khz. What a vile noise that makes!

so I figure that the primary impedance is too high (5k) making the amplifier oscillate, when I wire one half of my bi-poles (8 ohms) there is no oscillation, however there is no baffle-step correction either!

do I dare wire the drivers on each speaker in parallel (4 ohms) dropping the primary impedance to 1250 ohms? or is that too low?

I'm guessing I'm just going to re-wire it for 2500ohms on a 16ohm load. will that work?

-Moose
  Reply With Quote
Old 19th June 2008, 06:52 PM   #9
diyAudio Member
 
Miles Prower's Avatar
 
Join Date: May 2005
Location: USA
Blog Entries: 6
^^^^

Those Fostex drivers seem to be doing something squirrelly with the phase stability. In cases like this, time to get out the o'scope and signal generator and find out what the problem frequency is. That 15 -- 20KHz probably isn't it, and that is most likely a heterodyne of a much higher frequency. Ultrasonic oscillation probably also explains why the thing sounded "off" in the first place.

The other thing to consider is that the feedback be taken from the same OPT tap that the speeks are connected to. Frequently, it's connected to the highest tap even if it isn't being used, and that causes all sorts of problems.

You could tap off a smaller plate load at the expense of worse linearity to load down the parasitic circuit so that it can't oscillate, but that's more of a ghetto method. The real problem isn't really solved.
__________________
There are no foxes in atheistholes
www.dolphin-hsl.com
  Reply With Quote
Old 19th June 2008, 07:36 PM   #10
diyAudio Member
 
Join Date: Mar 2006
Location: Michigan
That makes sense, I took a measurement, when the amplifier was working "fine" (junky speakers) and Measured a Gain of 100, nothing screams "oscillation" like a gain of 100 from a pentode amplifier with 3db of Negative feedback....

Now that I think about it, the capacitor gave the amp an 8ohm load way up there (the oscillation frequency) which kept it out of the audible range, when the load changed to 16ohms, the oscillation frequency got pushed down into the audible range.

I have no o'scope, but I have a frequency Gen, do I see what freq makes the amplifier loose stability? or do I have to see what frequency the amp is producing when it looses stability?. In any event, I'll start poking around, and see if I can find some other culprit. now that I know its not the 5k on the tube, I'll poke around.


-Moose
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Old meets new but can this be solved? barchetta Pass Labs 4 11th March 2007 07:29 PM
A small no-fuss pentode/pentode SE amp Tubes4e4 Tubes / Valves 13 1st January 2006 05:16 AM
Old Meets New philipbarrett Tubes / Valves 3 22nd August 2005 12:03 AM
I need some pictures from DIY AUDIO meets - Can YOU help? SkinnyBoy The Lounge 10 7th September 2003 12:46 PM


New To Site? Need Help?

All times are GMT. The time now is 02:43 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2