doesn't sound quite right - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Thread Tools Search this Thread
Old 6th May 2008, 10:39 PM   #1
diyAudio Member
Join Date: May 2008
Default doesn't sound quite right

A friend of mine and I built a 6bq5 amp with 12at7 preamp. Anyhow, after much trial and error, I got it running and it sounds kinda hollow on most of my CD's. Lots of mid not much else really. It doesn't have any tone control type circuitry in it. Now in the process of getting it set up, I accidentally put the 6bq5's in the 12at7 sockets and vice versa. I wasn't sure if this would damage the tubes sufficiently to make it sound worse than expected. I will try to get a scan of the schematic on here tomorrow. I have to scan it when I get home (I'm at work now . Any help would be greatly appreciated. Thx
  Reply With Quote
Old 6th May 2008, 11:23 PM   #2
SY is offline SY  United States
diyAudio Moderator
SY's Avatar
Join Date: Oct 2002
Location: Chicagoland
Blog Entries: 2
Take DC voltage readings (caution, DEADLY stuff in there!) around the circuit and note it on the schematic. That will greatly help troubleshooting. Especially important are cathode and plate voltages.
“Instead of Rational Law, objective truths perceptible to any who will undergo the necessary intellectual discipline, Knowledge will degenerate into a riot of subjective visions. . ." - Auden
  Reply With Quote
Old 7th May 2008, 01:57 AM   #3
diyAudio Member
Ty_Bower's Avatar
Join Date: Mar 2007
Location: Newark, DE
Photos and a parts list might help, too. Is it single ended? Push pull? What kind of transformers did you use?
  Reply With Quote


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Datasheet for JRC2039G - the whole WWW doesn´t know ... Groundloops Parts 10 18th February 2007 09:40 AM
PC doesn't boot Devil_H@ck Everything Else 41 8th June 2005 09:41 PM
Why doesn't this sound dreadful? bigwill Full Range 16 2nd May 2005 05:06 PM
Amp doesn't like computer :/ Bryanm Solid State 1 18th June 2003 11:02 PM

New To Site? Need Help?

All times are GMT. The time now is 05:03 PM.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright ©1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2