Meixing MingDa MC767-RD - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th March 2008, 03:14 PM   #1
diyAudio Member
 
Join Date: Mar 2008
Default Meixing MingDa MC767-RD

Hi there!

As I already said in my apresentation, I have recently buy this phono stage in order to introduce valves in my system..

When I first connect the phono stage I notest lower bass and a litle distortion on the sound.

Then I start to investigate the cause, and some people say to me that it could be because of the high Output impedance of the phono stage and the low input impedance of the pre amplifiar.

Here are the specs:

Meixing -> Phono
Input level MM: 2.5mv
Input impedance MM: 47kO
Signal to noise ratio MM: 91dB
Output impedance MM: 100kO
Input jack: 1 group
Output jack: 1 group
Vacuum tubes: 6N6x1(rectifying tube) 5687x1 12AX7x1 6N3x2(amplify)
Power supply: AC110V/220V 60Hz/50Hz
Weight: 9Kg


Rega Cursa1 -> pre amplifier
Note - Factory setting of gain range level 2
CD, tuner, Line 1, line 2, Tape input sensitivity = 220mV Load, 10K Ohm
Pre-amp output level (with rated input levels)
Level 1 = 212mV @ 100 Ohms
Level 2 = 830mV @ 100 Ohms
Level 3 = 1.25V @ 100 Ohms
Maximum output level 8.8V
Pre-amp out 1&2 are connected in parallel.
The pre-amp output is DC coupled with full DC protection.


Here are the fotos of the meixing:

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.

As one of the solutions some pointed me to connect a buffer stage..

Is this the best solution? Is there possible to change the meixing in order to low the output impedance?

I've tried to see what are the B+ Voltage, but I don't now where can I see it.. Or where should I connect my multimeter.

Thanks in advance
  Reply With Quote
Old 17th March 2008, 01:58 PM   #2
diyAudio Member
 
Join Date: Mar 2008
Hello??
  Reply With Quote
Old 15th April 2008, 05:48 PM   #3
jnorre is offline jnorre  Denmark
diyAudio Member
 
Join Date: Dec 2005
Location: Jutland
Hi,

I have one of these - the old version, but it seems to be the same inside. I measured it to be 9dB down at 20Hz so it is very bass shy. I tried adding an output buffer, but to no avail - the 6N3 tubes (which was the compatible 5670WA in my amp) does not have enough amplification to make the RIAA network work correctly. Also, the older version has an error in the power supply, which I was able to track down (Meixing/Mingda sent me a schematic up on request) to some wrong wiring. I ended up keeping the corrected power supply and modifying the RIAA to a Hagerman "Cornet" inspired design (with 12AX7), for which I used the existing 5670WA tubes as output stage.
So if you need some inspiration or help, just ask and I'll do my best.

Best regards,
Johnny
  Reply With Quote
Old 15th April 2008, 06:22 PM   #4
diyAudio Member
 
Join Date: Mar 2008
Hi!!!


Yes! I need help, and any help is very welcome!

I've sent an e-mail to Ming-Da requesting a schematic, but with no answer.

How can I now if this Ming-Da is the older or the new version??

Can you send me that schematic?

Do you now how can I lower down the output impedance to a maximum of 10K???

Thanks!
  Reply With Quote
Old 15th April 2008, 06:58 PM   #5
jnorre is offline jnorre  Denmark
diyAudio Member
 
Join Date: Dec 2005
Location: Jutland
You have the new one. The old one is more wide than deep, while the new one is more deep than wide. Also, the old one had two switches on the front - one for on/off and one for MM/MC (the MC setting was totally useless!). Regarding the schematics, I'll try to upload them to my web-page later tonight. I'll have to get back with the suggestion for an output buffer - and as mentioned, it does not help at all with the bass problem.

Best regards,
Johnny
  Reply With Quote
Old 15th April 2008, 09:11 PM   #6
jnorre is offline jnorre  Denmark
diyAudio Member
 
Join Date: Dec 2005
Location: Jutland
Hi,

I have made a quick web-page with the schematic and some photos at http://www.norre.dk/mc767rd/riaa.html.

At the first picture, you see my MC767 inside (there a few modifications to the RIAA section - this was while I was trying to make the original construction work). You can see it is very much like yours. In this picture I've highlighted B+ (and an alternative "almost B+" which is easier to access).
The second picture shows the modified MC767 with 3 tubes to the left instead of 2 tubes. You can see that your new version is simply turned 90 degrees compared to my older version.
The third picture shows the modified MC767 inside. The power supply has the modifications (I have written these on the schematic), a capacitor has been added and the RIAA is totally changed.

You can add a transistor buffer (or FET buffer) to the output. The problem is, where to get the voltage for the buffer. The easy point is highlighted in blue in picture 1 - there is a point with 18V. This point has two disadvantages: It is unstabilized and the voltage is too small! One of the advantages of a valve RIAA is the high voltage swing it is capable of. With 18V the voltage swing is realistically 6V-7V rms which is too low (I tried it and with a high output MM is could distort in loud passages). So I made the one shown on the page instead: It has 36V supply and 15-16V rms which did it in my case. This calls for a 36V power supply, which is displayed at the bottom of the page. Please note that R1=15kohm should be at least 10W (I used a 17W resistor) as the voltage drop is 264V and the currents in the schematic is when no signal is applied to the buffer. The 300V is taken from B+ and is actually a little lower.

I hope this helps.

Best regards,
Johnny
  Reply With Quote
Old 29th September 2008, 09:10 PM   #7
diyAudio Member
 
Join Date: Sep 2008
Hi !!
I am from Chile and I love the valve amplifiers. On march I bought a phono stage Meixing Ming Da MC-767-RD, directly from China.

I found the same problem than Gorogoro (very low bass) and I will appreciate very much if you can share your experiences. In my country I have talked with a technical who told me that de RIAA in this amplifier is wrong, that is the same that you, Johnny, say.

Please, I really need your help.
Best regards.

Jose Miguel
  Reply With Quote
Old 29th September 2008, 09:26 PM   #8
Cobra2 is offline Cobra2  Norway
DIY !
diyAudio Member
 
Cobra2's Avatar
 
Join Date: Apr 2002
Location: Stavanger, Norway
Send a message via Skype™ to Cobra2
Schematic...

Arne K
Attached Images
File Type: jpg mc 767-rd dfs.jpg (56.0 KB, 698 views)
__________________
Don't believe everything you think...
  Reply With Quote
Old 29th September 2008, 11:05 PM   #9
diyAudio Member
 
Join Date: Sep 2008
Thank you !!
Excuse me... but, does the schematic have the modifications?
  Reply With Quote
Old 3rd October 2008, 11:39 AM   #10
diyAudio Member
 
Join Date: Sep 2008
Hi !!
I have changed the configuration, following the schematic, but the sound didn't improve

I am thinking that the best solution is to re-make again the amplifier circuit, keeping the same power supply...

Do you have any idea about what circuit I can use?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MeiXing MC-805AA biasing audiomatic Tubes / Valves 2 25th March 2009 09:42 PM
Meixing 3008ab problems laundry2000 Tubes / Valves 3 11th May 2007 08:31 AM
another mingda carcass Tubes / Valves 3 9th March 2007 01:42 AM
meixing 805 tube amp problems pjpoes Tubes / Valves 11 21st October 2006 03:54 PM
Modding MEIXING MC 3008 pjpoes Tubes / Valves 1 10th October 2006 11:57 PM


New To Site? Need Help?

All times are GMT. The time now is 04:44 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2