Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Hissing Sound in KT88 Amp
Hissing Sound in KT88 Amp
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Thread Tools Search this Thread
Old 22nd October 2007, 07:12 AM   #1
alfcat is offline alfcat  Hong Kong
diyAudio Member
Join Date: Oct 2007
Default Hissing Sound in KT88 Amp

Hi, I am a newbie to this forum.

There is a Hissing sound coming from my KT88 amp once it has been used for > 3 hours. It won't occur each and every time but the chance of having this annoyance is > 70%.

The Caps were changed but the situation still persists. What could be the cause?

Please advise.

Many thanks
  Reply With Quote
Old 22nd October 2007, 08:15 AM   #2
DigitalJunkie is offline DigitalJunkie  United States
diyAudio Member
Join Date: Apr 2003
Location: Portland,Oregon
Send a message via AIM to DigitalJunkie
  Reply With Quote
Old 22nd October 2007, 08:41 AM   #3
ray_moth is offline ray_moth  Indonesia
diyAudio Moderator Emeritus
ray_moth's Avatar
Join Date: Jan 2004
Location: Jakarta
Without more information about the design of your amp, any suggestion is just a guess.
  Reply With Quote
Old 22nd October 2007, 09:05 AM   #4
felixx is offline felixx  Romania
diyAudio Member
felixx's Avatar
Join Date: Feb 2005
Location: in center
Your tube sockets is brand new?
"I'm glad I can build my own mistakes."
  Reply With Quote


Hissing Sound in KT88 AmpHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with Dac AH - loud hissing sound johnnyccs Digital Source 1 14th February 2009 07:50 AM
Hissing DCX2496 MikeHunt79 Digital Line Level 2 27th January 2009 04:34 PM
Static like hissing sound eminating from power amp. Brit01 Solid State 16 8th November 2008 01:17 PM
Hissing noise from a sub DECKY999 Subwoofers 6 14th February 2008 12:48 AM
How come my modded Sonic-T keep having "hissing" sound? poozebear Class D 17 28th June 2006 04:43 PM

New To Site? Need Help?

All times are GMT. The time now is 08:08 PM.

Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio