Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Problem with a solid state CCS
Problem with a solid state CCS
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th October 2007, 08:00 AM   #1
croccodillo is offline croccodillo  Italy
diyAudio Member
 
croccodillo's Avatar
 
Join Date: Mar 2005
Location: Bergamo
Default Problem with a solid state CCS

Hi all,

I'm building a SE amp; the input stage is made with a 6N6P valve, loaded with a SS CCS at 20mA.
The CCS schematic is THIS ; it uses a TL431 shunt regulator to regulate the current.
It works fine, during the test on the bench the current was stable and perfectly regulated; once connected to the high voltage power supply (400V) it begin to oscillate, I can see a sine wave of about 1V superimposed to the output voltage at the mosfet source (measured with respect to the comm level).
The sine has a frequency of about 13 Mhz!
It seems the TL431 oscillate when I increase the power supply over, let's say, 30V, trying to keep the current stable.
How can I solve the problem?
Any idea?
Thanks in advance.


Ciao,
Giovanni
__________________
In Nomine Libertatis Vincula Edificamus,
In Nomine Veritatis Mendacia Efferimus.
  Reply With Quote
Old 10th October 2007, 01:31 PM   #2
Alastair E is offline Alastair E  Wales
diyAudio Member
 
Alastair E's Avatar
 
Join Date: Feb 2004
Location: South Wales
You could try a 'Gate-Stopper' of around 100 K in series with the gate of the Mosfet....

Mount as close to the Mosfet as possible....

Worth a try....
__________________
Das Beste Oder Nichts
  Reply With Quote
Old 10th October 2007, 02:02 PM   #3
ilimzn is offline ilimzn  Croatia
diyAudio Member
 
Join Date: Feb 2005
Location: Zagreb
100 K?? You sure it's not supposed to be 100 ohm?
  Reply With Quote
Old 10th October 2007, 02:38 PM   #4
croccodillo is offline croccodillo  Italy
diyAudio Member
 
croccodillo's Avatar
 
Join Date: Mar 2005
Location: Bergamo
Already tried.
A 10K "gate stopper" resistor installed there create a 5V, 310Khz perfect sine output wave...
I think I will change CCS topology.
__________________
In Nomine Libertatis Vincula Edificamus,
In Nomine Veritatis Mendacia Efferimus.
  Reply With Quote
Old 10th October 2007, 04:14 PM   #5
Alastair E is offline Alastair E  Wales
diyAudio Member
 
Alastair E's Avatar
 
Join Date: Feb 2004
Location: South Wales
Quote:
Originally posted by ilimzn
100 K?? You sure it's not supposed to be 100 ohm?
Absolutely!--

Its what Ive always used to good effect!

croccodillo--

Just try a 100K before re-design...Might save you the trouble....
__________________
Das Beste Oder Nichts
  Reply With Quote
Old 10th October 2007, 04:41 PM   #6
Boris_The_Blade is offline Boris_The_Blade  United States
diyAudio Member
 
Boris_The_Blade's Avatar
 
Join Date: Mar 2007
Just a shot in the dark here without the circuit to bend test, but you might try some additional feedback in parallel with the 10k resistor as well. Off the top of my head, you might try a 2.2k resistor in series with 270pF across that R11 (10k). There are a few other things i can think of to stabilize it, but one at a time i suppose.
  Reply With Quote

Reply


Problem with a solid state CCSHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem With Hight Power Solid State Amplifier vytas Solid State 8 3rd September 2004 03:49 PM
Problem With Hight Power Solid State Amplifier vytas Solid State 0 2nd September 2004 03:54 PM
The Solid State Wiki - Your solid state reference guide Jason Solid State 0 25th June 2002 06:26 PM


New To Site? Need Help?

All times are GMT. The time now is 04:00 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki