Pop from amp when turning off - diyAudio
Go Back   Home > Forums > Amplifiers > Tubes / Valves

Tubes / Valves All about our sweet vacuum tubes :) Threads about Musical Instrument Amps of all kinds should be in the Instruments & Amps forum

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st September 2007, 12:16 PM   #1
speed3 is offline speed3  United States
diyAudio Member
 
Join Date: Jan 2005
Location: Maine
Default Pop from amp when turning off

I'm having an issue with one of my tube amps "popping" after shutting off. About 1.5 seconds after the amp is turned off, there is a distinct pop from the speaker. There is also a slight gritty hum coming from the speaker when the amp is on. I swapped some tubes out, but that didn't mak a difference. Is this a capacitor issue? ANy suggestions for me to look into?

Thanks for your help.
  Reply With Quote
Old 22nd September 2007, 03:26 AM   #2
ArtG is offline ArtG  United States
diyAudio Member
 
Join Date: Nov 2006
Location: Central PA
I've seen this problem quite a bit. However, it's more common with solid state equipment, although tube circuits sometimes show this issue, often for different reasons. Providing a little more information would be quite helpful. First, you need to isolate the problem to a specific piece of gear. I'm going to assume that since you say "amplifiers". that you may be running monoblocks. If that's the case, then you should short the input of each amplifier, and see if the "popping" goes away. If so, your problem is quite likely further "upstream" in your line stage, switching system, tuner, etc.

After you have isolated the offending unit, I'd start be cleaning all the connectors, switches, and tube sockets and tube pins, with a spray cleaner designed specifically for the job.

This will often resolve the issue. If not, then you will have to look into the circuitry, and check for circuit board cracks, cold solder joints, loose connections, or an obviously charred resistor, etc. Beyond that, it will depend somewhat on your experience with electronics. Unless you have troubleshooting experience on tube circuits, you could be better off by having someone else find the offending component--possibly a resistor or capacitor.
  Reply With Quote
Old 25th September 2007, 04:59 PM   #3
speed3 is offline speed3  United States
diyAudio Member
 
Join Date: Jan 2005
Location: Maine
Thanks for the advice. I've definitely narrowed it down to one of my monoblocks. I will take it apart and perform a thorough inspection and cleaning. If that doesn't cure it, I'll look into getting some professional help if necessary.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
This is how my new amp is turning out.. nikwal Solid State 5 7th October 2007 01:34 PM
Are there any way of turning DC to AC jacquesl Power Supplies 32 2nd March 2007 09:40 PM
Turning a car amp into a pc amp JDAudio Solid State 3 16th September 2004 05:10 PM
Turning Pro griff Everything Else 33 3rd October 2002 09:31 AM


New To Site? Need Help?

All times are GMT. The time now is 10:44 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2