SSE grounding - diyAudio
Go Back   Home > Forums > Commercial Sector > Vendor Forums > Tubelab

Tubelab Discussion and support of Tubelab products, prototypes and experiments

Reply
 
Thread Tools Search this Thread
Old 1st April 2013, 09:09 PM   #1
rock12 is offline rock12  United States
diyAudio Member
 
Join Date: Nov 2010
Location: midland mi
Default SSE grounding

Now that mi. warmed a bit I got out to the shop and drilled my top plate. Amp has been running in a temp set up. Pic of layout included. The input jacks are on top and I take it that I come off one of the grounding lugs and run to the power input ground, everything else grounds thru the plate? (I will check every thing with my multimeter)
Attached Images
File Type: jpg IMG_0498.jpg (615.1 KB, 49 views)
File Type: jpg IMG_0497.jpg (652.5 KB, 45 views)
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SSE grounding question neonthecat Tubelab 10 1st October 2013 05:00 PM
Auricaps in SSE and SSE as a guitar amp. DanP Tubelab 5 12th July 2010 09:20 AM
Lions and Tigers and Grounding Problems, Oh My! DoZ Grounding... EchoWars Solid State 37 3rd August 2008 08:50 AM
LM3875 kit grounding, optimal grounding for separate amps and psu? findog Chip Amps 9 16th May 2005 09:27 PM


New To Site? Need Help?

All times are GMT. The time now is 04:55 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2