WTB: Phono Preamp (~$100 range?) - diyAudio
Go Back   Home > Forums > Commercial Sector > Swap Meet

Swap Meet Sell your stuff here, who knows, some other fanatic might be interested!

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th February 2013, 02:39 AM   #1
5k3105 is offline 5k3105  United States
diyAudio Member
 
Join Date: Feb 2013
Default WTB: Phono Preamp (~$100 range?)

Anyone have a phono preamp they are willing to part with?

Thought I might ask up front before trying to assemble one myself.


Thanks.
  Reply With Quote
Old 12th February 2013, 03:56 AM   #2
limono is offline limono  United States
diyAudio Member
 
Join Date: Mar 2007
how about this ? $13.95 ready to go not some DiY junk
Phono Preamp Turntable Record Player Pre Amp Amplifier | eBay
  Reply With Quote
Old 12th February 2013, 06:55 AM   #3
5k3105 is offline 5k3105  United States
diyAudio Member
 
Join Date: Feb 2013
Hi,

I tried a similar small preamp box called a PYLE PP999 (though it doesn't have a grounding screw like the one you link) and it gives a lot of line noise, even though it got good reviews on amazon.

I was thinking about the TEC preamp, also listed here:

Phono Preamp Pre Amp Amplifier 2INPUTS Volume Control | eBay

but still not sure.
  Reply With Quote
Old 12th February 2013, 10:28 AM   #4
diyAudio Member
 
merlin el mago's Avatar
 
Join Date: Sep 2009
Location: Catalonia - Europe
What about this? Azur 551P Phono Pre-amplifier
  Reply With Quote
Old 12th February 2013, 06:13 PM   #5
5k3105 is offline 5k3105  United States
diyAudio Member
 
Join Date: Feb 2013
I got the Pyle grounded last night and had a listen. At first I was surprised at how much gain there was.

I felt like the response was very flat.

Compared to the receiver I was using before, the Pyle through my Sony was loud but lifeless.

The receiver I used before was a KLH Model 55. After a month of use the left channel died. I noticed that before it died, when I would turn the volume knob down to the off position, the volume would get loud rush of static just before it switched off.

I got a strong, clear and animated sound from this receiver and I'm afraid I won't be able to find a reasonably priced amp to replace it.

I wonder if I took a picture of the KLH board someone here could spot the defective component. I took a look and I couldn't tell, but part of the board is messy with a white coating over some of the components.
  Reply With Quote
Old 12th February 2013, 06:28 PM   #6
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
I've never heard of KLH tbh.

If you want to post a detailed picture showing this "white coating" perhaps we might get an idea although I suspect its going to be a bit more involved than just swapping one or two components... but you have to start somewhere.
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
  Reply With Quote
Old 12th February 2013, 08:42 PM   #7
5k3105 is offline 5k3105  United States
diyAudio Member
 
Join Date: Feb 2013
first set
Attached Images
File Type: jpg CIMG0073.jpg (539.2 KB, 47 views)
File Type: jpg CIMG0074.jpg (405.3 KB, 47 views)
File Type: jpg CIMG0075.jpg (509.0 KB, 47 views)
File Type: jpg CIMG0076.jpg (1.03 MB, 47 views)
File Type: jpg CIMG0077.jpg (1.01 MB, 45 views)
File Type: jpg CIMG0078.jpg (913.9 KB, 8 views)
File Type: jpg CIMG0079.jpg (1.04 MB, 7 views)
File Type: jpg CIMG0080.jpg (1,009.3 KB, 5 views)
File Type: jpg CIMG0081.jpg (1.02 MB, 2 views)
File Type: jpg CIMG0083.jpg (935.6 KB, 7 views)
  Reply With Quote
Old 12th February 2013, 09:04 PM   #8
5k3105 is offline 5k3105  United States
diyAudio Member
 
Join Date: Feb 2013
second set
Attached Images
File Type: jpg CIMG0084.jpg (1,007.0 KB, 6 views)
File Type: jpg CIMG0085.jpg (639.8 KB, 1 views)
File Type: jpg CIMG0086.jpg (823.5 KB, 0 views)
File Type: jpg CIMG0087.jpg (891.0 KB, 2 views)
File Type: jpg CIMG0088.jpg (609.7 KB, 4 views)
File Type: jpg CIMG0089.jpg (680.6 KB, 2 views)
File Type: jpg CIMG0090.jpg (986.1 KB, 6 views)
File Type: jpg CIMG0091.jpg (1,023.1 KB, 8 views)
File Type: jpg CIMG0092.jpg (1.01 MB, 3 views)
File Type: jpg CIMG0093.jpg (918.2 KB, 3 views)
  Reply With Quote
Old 12th February 2013, 09:09 PM   #9
5k3105 is offline 5k3105  United States
diyAudio Member
 
Join Date: Feb 2013
last 2
Attached Images
File Type: jpg CIMG0094.jpg (724.6 KB, 7 views)
File Type: jpg CIMG0095.jpg (852.5 KB, 10 views)
  Reply With Quote
Old 12th February 2013, 09:13 PM   #10
tinitus is offline tinitus  Europe
diyAudio Moderator R.I.P.
 
Join Date: Nov 2005
looks like it got a good slash of white paint
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Phono Preamp PCB wanted - Transcendental Sound Grounded Grid Phono Preamp nathanjh13 Analogue Source 0 14th June 2012 10:19 AM
WTB: Tetra Phono Preamp PCB jono1 Swap Meet 0 19th February 2011 08:29 PM
WTB : Power Supply Board for ONO Phono preamp Clone (From Group Buy) dtm1962 Swap Meet 3 4th April 2010 06:03 PM
WTB : Power Supply Board for ONO Phono preamp Clone (From Group Buy) dtm1962 Pass Labs 0 2nd April 2010 04:05 PM
WTB: 2 Relays for Pass Labs ONO Phono preamp (Meder DIL24-2C90-63L) dtm1962 Swap Meet 0 28th March 2010 07:19 AM


New To Site? Need Help?

All times are GMT. The time now is 07:18 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2